[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: wireless on an old Thinkpad 600 - more specifically sound on 600E


Justin Joseph <justinjoseph007@gmail.com>:
> The problem with sound on 600E is I understand a Historical one. I
> owned the 600E for sometime and had faced this problem. I remember
> that the problem is the fact that though the 600E sound chip is of
> a particular make, it is detected as something else.
> I remember solving it by uninstalling discover and a combination of
> blacklisting and modprobing the right drivers(not sure though) It's
> been years since I parted with the 600E.
> ThinkWiki describes this problem:
> http://www.thinkwiki.org/wiki/Problem_with_broken_sound_on_ThinkPad_600
> And am sure there would a a lot and lot of google hits for the same,
> because like I mentioned it is a very well known problem.

Clayton <ckoeni@gmail.com>:
] Indeed, there is an awful lot of advice out there about how to get the
] 600 / 600e's sound working, and everyone's advice seems to be a little
] different. I burnt off three more hours this eve trying the above Think-
] Wiki suggestions for my 600e, plus various other ALSA module blacklist
] / modprobe voodoo, all to no avail. Another machine that does not work
] with ALSA....
] Actually, the root problem is probably deeper then ALSA (IRQ conflict?)
] as in its current state, not even USB audio works for me. USB audio has
] *always* worked on my other machines, without exception.

Sorry to hear of your troubles. I too am a proud owner of a ThinkPad
600, and getting sound set up used to give me fits practically every
other release of Debian. Then I managed to stumble upon a tried and
true recipe.

However, this time around, with Debian 4.0r4, that tried and true
recipe failed to work. Then, a couple of days later, it worked. And
I truly changed nothing in the interim. So my advice is to try the
recipe I'm enclosing here.

PostPosted: 2008-08-15 23:42    Post subject: Re: Sound on Thinkpad 600


On the very same Thinkpad 600 (Type 2645-51U, BIOS IBET53WW), my
previously noted steps failed to get sound working under Debian 4.0r3
and were on track to fail again under (a clean installation of) Debian
4.0r4 (Testing branch). Very frustrating. However, I did, for some
reason, finally achieve success under Debian 4.0r4.

The steps:

0.  BIOS (enter BIOS by pressing F1 key while booting)

    a.  Select "Initialize".
    b.  Select "Disable Quick Boot".

1.  Packages

    a.  alsa-utils (in order to get /usr/sbin/alsaconf, which seems to
        be necessary again)
    b.  mpg123 (for my console sound test)
    c.  xfmedia (for my X Window System sound test)

2. </etc/modules> file

    Must contain these lines:

3.  </etc/modprobe.d/sound> file

    Must contain these lines:
    alias snd-card-0 snd-cs4236
    options snd-cs4236 index=0 isapnp=0 port=0x530 cport=0x538 irq=5 \
    dma1=1 dma2=0

4.  Blacklist snd-cs4232 module

    File </etc/modprobe.d/alsa-base-blacklist> must contain these lines:
    # blacklist snd-atiixp-modem
    # blacklist snd-intel8x0m
    # blacklist snd-via82xx-modem
    blacklist snd-cs4232

Now, for whatever reason, these 4 steps, while sufficient under Debian
4.0r0, were not sufficient under 4.0r3 and may not be sufficient under
4.0r4. Additionally, I needed to:

5.  Run alsaconf(8)

    Here is where things got strange. I ran </usr/sbin/alsaconf> and
    tried to autoprobe my sound card. It of course again mistakenly
    found a cs4232 card. On my first go around, I told it to continue
    searching for ISA legacy cards; it found one, and I let it rewrite
    my </etc/modules> and </etc/modprobe.d/sound> files. Upon rebooting,
    I of course had no sound. I then reran </usr/sbin/alsaconf> and ac-
    cepted that there was a cs4232 card on board. Upon rebooting, the
    system hung. After performing a Debian rescue and removing the of-
    fending entries in </etc/modules> and </etc/modprobe.d/sound>, I
    rebooted. Then I manually followed the first 4 steps above, reboot-
    ed, and lo, I had sound. Aggravating to not know why it worked now
    while before it didn't.

Regardless, there you have it for sound on a Debian 4.0r4 (Testing
branch) on a Thinkpad 600 (Type 2645-51U, BIOS IBET53WW).

Eric De Mund

Eric De Mund   | Ixian Systems           | Jab: eadixian@jabber.org/main
ead@ixian.com  | 650 Castro St, #120-210 | Y!M: ead0002
ixian.com/ead/ | Mountain View, CA 94041 | ICQ: 811788

Reply to: