[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: cpu fan not running in laptop

Leonardo Canducci, 12.09.2008 tarihinde şöyle yazmış:
> I've been using debian for a long while then switched to ubuntu on my laptop for suspend to ram support.
> This week I decided to give lenny a try and installed it on the laptop. Everything seemed to go fine (except s2ram) but then I noticed that the fan never turned on. I made some tests with cpu intesive tasks and realised it actually never runs. I put on a xubuntu livecd and the fan was back again, when needed.
> My laptop is a 2004 acer travelmate290 with a 1.4 centrino and intel 855gm graphics. In 2004 it was running sarge and fan was ok.
> I noticed powernowd and was not installed and speedstep-centrino is not loaded at boot, though cpu scaled anyway.
> At boot I see a "gpe storm" acpi error. I tried passing acpi_osi="Linux" at boot and the message disappeared though still I have no fan running.
> Everything was fine with sarge, ubuntu 8.04 and its livecd but fan is not running in lenny. I think this is a very serious problem since cpu is overheating.
> What should I do? 
> Leonardo

Is the module "thermal" loaded?   On my laptop (Averatec 3250) the fan 
runs but on very rare occasions it stops running.  If I notice it 
getting hot but the fan staying off, `modprobe -r thermal` followed by 
`modprobe thermal` brings it back on.  Maybe you could try that.
(When I tried suspending to disk many years ago, the fan wouldn't come 
back on when I resumed, but the same unload/load trick worked.)

Reply to: