[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Thinkpad R61i : Brightness Problem with Fn keys

> if you get this message one of the following things is true:
>   - you are on the wrong host
Not sure about that. I logged in as user. cannot login as root into X.

>   - you screwed up your X session
Not sure about that either. But recently i updated the Xorg intel .
Would this have messed up the Xorg conf.

>   - no other X programm is working
yes. X session is running.

>   - your entries in /etc/hosts are wrong
Below is the etc/hosts entirs :
-----------       localhost       debian

# The following lines are desirable for IPv6 capable hosts
::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts

>   - someone/sometool set the DISPLAY env variable wrong
I was doing some experiments using export DISPLAY for the problem.
That y the DISPLAY was showing "debian:0.0.
I have rebooted and below is the DISPLAY varibales:
debian:~# echo $DISPLAY
debian:~# xbacklight -get
No protocol specified
Cannot open display ":0.0"
> if you are on the correct host, with the correct user:
>   then setting DISPLAY to :0.0 should work.
Still not working

> but normal if you get the error, no other X programm like firefox,
> xclock, any kde or gnome programm is working.
Other X programs are runnig : iceweasel, KPPP dialler , ktorrent etc

Any inputs regarding the above?


Reply to: