[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: suspend2ram doesn't turn off the screen anymore on Thinkpad X31 after lenny upgrade


I'm using X31 with unstable and it works great.
The packages hibernate and uswsusp in fact work for me out of the box both for 
suspending to disk (/usr/bin/hibernate) and to ram (/usr/bin/susp2mem).

>  1. I "echo mem > /sys/power/state" (i know this is deprecated, but this
>  is how it always worked here)

>  2. The suspend process goes on normally (the screen turns off, the
>  "moon led" flashes, and the laptop goes to sleep)
>  3. When the "moon led" goes solid (ie. the laptop is suspended), the
>  screen *turns itself on* for some reason
>  4. When i resume, everything comes back to normal (X11 and everything
>  comes back up)
> I suspect the problem is related to ACPI, as I've heard that part of
> 'testing' is in flux. Also the fact that the screen actually turns
> itself *off* while the laptop goes to sleep but really turns itself back
> up when the computer is really asleep is a dead giveaway: ACPI *must* be
> broken somewhere.
> I have tried upgrading Xorg to unstable (of course no effect), upgrading
> all the acpi* packages I could find (no effect). Also note that uswsusp
> and hibernate do not work on this laptop, last time I checked (ie. in
> sarge).
> I'd be happy to proceed to whatever required debugging to go through
> this problem, as I use this functionality a lot. :)
> Thanks for any pointers,
> A.
> PS: please CC me, i'm not on the list

 Damjan Vrenčur <~> http://lmmri.fri.uni-lj.si/damjan/ <~> GPG key: C6A3146F

Reply to: