[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: How to get Acer 5570z´s modem working?

On Wed, 17 Oct 2007 22:50:38 -0300
Bruno Buys <bruno.grupos@gmail.com> wrote:

> Celejar wrote:
> > On Thu, 18 Oct 2007 10:01:30 -0300
> > "Bruno Buys" <bruno.grupos@gmail.com> wrote:
> >
> >   
> >> Did someone manage to get the modem that comes with the notebook Acer
> >> 5570z working?
> >> It doesn´t show up in lspci or lsusb.
> >> System is debian sid, kernel 2.6.22 for i686. The rest of the hw is working
> >> ok (including wifi and webcam).
> >>     
> >
> > I can't get my Acer 3690's modem to work; it's apparently a Conexant /
> > Intel softmodem integrated into the soundcard, and it apparently needs
> > a proprietary driver from linuxant.  Try scanmodem [0]; also see the
> > rest of that page.
> >
> > I gave up and bought a Xircom PCMCIA hardware modem on Ebay.
> >
> >   
> >> Thanks!
> >>     
> >
> > [0] http://linmodems.technion.ac.il/#scanModem

> Hi Celejar,
> Is it ok to email you directly?

Sure,  but I'm going to try to keep the discussion on list, if you
don't mind, so that others can benefit from anything we establish.

> I managed to get the modem kind of working... I ran the scanmodem 
> script, it pointed me to the slmodem driver
> from http://linmodems.technion.ac.il/packages/smartlink/ as said below:
>  Complementation of snd-hda-intel, slmodemd and a dialer utility
>  ---------------------------------------------------------
>  THe ALSA (Advanced Linux Sound Architecture} modem driver snd-hda-intel
>  provides ONLY a low level access to the hardware. The complementing HIGH
>  level support for ALSA  modem drivers is through a Smartlink utility:  
> slmodemd
>  An ALSA compatible and compiled slmodemd is in the package 
> SLMODEMD.gcc4.1.tar.gz
>  with download from http://linmodems.technion.ac.il/packages/smartlink/
>  Unpack under Linux with:
>      $ tar zxf SLMODEMD.gcc4.1.tar.gz
>  and read instructions therein.

I got that with an old scanmodem, but not (at least I don't currently
see it) with a current one.  scanmodem claims that I have a Conexant
softmodem requiring drivers from linuxant.

> The driver ships already compiled, curiously. It does load and work. In 
> kppp I was able to type AT commands into a miniterminal and talk to the 
> modem. I didn't complete any call, but this might be the line which is a 
> voip line of questionable quality. I was having problems with a 
> conventional telephone, so, I can't isolate it.
> Did you try the smartlink driver?

I've tried the SmartLink utility and sent AT commands, but I think they
are being answered by the SmartLink software and not by any actual
hardware.  I can't get a connection.

mailmin.sourceforge.net - remote access via secure (OpenPGP) email
ssuds.sourceforge.net - A Simple Sudoku Solver and Generator

Reply to: