[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

hardware acceleration in X?


I run Debian testing release (etch/lenny) on my Dell Latitude C600
laptop and I would like to get hardware acceleration working. Two
games I've tried told me it wasn't enabled.

Here is the relevant output from lspci:

01:00.0 VGA compatible controller: ATI Technologies Inc Rage Mobility
M3 AGP 2x (rev 02) (prog-if 00 [VGA])
        Subsystem: Dell Latitude C600
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping+ SERR- FastB2B-
        Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 32 (2000ns min), Cache Line Size: 32 bytes
        Interrupt: pin A routed to IRQ 11
        Region 0: Memory at f8000000 (32-bit, prefetchable) [size=64M]
        Region 1: I/O ports at ec00 [size=256]
        Region 2: Memory at fdffc000 (32-bit, non-prefetchable) [size=16K]
        [virtual] Expansion ROM at fd000000 [disabled] [size=128K]
        Capabilities: [50] AGP version 2.0
                Status: RQ=32 Iso- ArqSz=0 Cal=0 SBA+ ITACoh- GART64-
HTrans- 64bit- FW- AGP3- Rate=x1,x2
                Command: RQ=1 ArqSz=0 Cal=0 SBA+ AGP- GART64- 64bit-
FW- Rate=<none>
        Capabilities: [5c] Power Management version 2
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-

Here is my /etc/X11/xorg.conf:


I run X.Org 7.2-5

PS: I noticed when I upgraded to version 7.2 of X.Org (xserver-xorg)
it removed this section from my xorg.conf:

Section "DRI"
        Mode    0666


Reply to: