[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[solved] Re: automatic wlan connection at bootprocess on Etch only on second try?

Hi Freddy,

Am Montag, 2. Juli 2007 16:28 schrieb Freddy Freeloader:
> I had a very similar problem to yours, only my wlan connection would
> work on the first try about 3 out of ten times.  I ended up removing the
> "allow-hotplug" statement in /etc/network/interfaces for that ethernet
> device and replaced it with "auto".  Now mine works on the first try
> better than 95% of the time.
> It was something to do with udev but I can't recall the specifics right
> now.

now it works.

auto and allow-hotplug didn't work on my box.

This is my solution (for all others having the same trouble):

I modified /etc/network/interfaces this way:

iface eth2 inet dhcp
wpa-conf /etc/wpa_supplicant/wpa_supplicant.mynet.conf
#auto eth2

and in /etc/rc.local:

Etch-nb:~# cat /etc/rc.local
#!/bin/sh -e
# rc.local
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
# In order to enable or disable this script just change the execution
# bits.
# By default this script does nothing.

ifup --verbose eth2
exit 0

This configuration makes the machine connecting to my WLAN at the first try 
without any errors. :-)))

Thank you Frank and Freddy!


Reply to: