[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re:Broken ACPI with kernel 2.6.18-4-686 in HP nx6110 laptop

> I have a problem with my HP Compaq nx6110 laptop.
> Since upgrading to Kernel 2.6.18-4-686 (currently running
> 2.6.18.dfsg.1-12) on Debian Etch I've been unable to get
ACPI to work
> on the machine. As a result I don't get any battery or AC
status and
> the machine doesn't power off properly when I shut down.
> The modules acpi gives a fatal error (no such device) when I try
> modprobe acpi
> or
> modprobe battery
> or
> modprobe ac
> I then compiled a custom 2.6.20 kernel downloaded from
kernel.org and
> ACPI works perfectly with that. But unfortunately, compiling a
> pristine kernel.org kernel against Debian breaks other
things like the
> iptables setup.
> Then I installed the Debian linux kernel sources 2.6.18-4
from the
> repository and tried to compile it after going through "make
> but that it has the same problem (no ACPI) even when I
compiled all
> the ACPI related modules in the kernel. I used the option
> make-kpkg --initrd linux-image
> to compile the kernel the "Debian way".
> So I want to know whether anybody else has had this ACPI
problem with
> their laptop. I am 99% sure that it's a kernel problem and not a
> problem with "acpid" because of what I mentioned above. I've
> everything, but nothing works with the current Debian kernel
in Etch
> on my laptop.
> If you need any other information, I'll send it to the list
after I
> boot up my laptop.
> Regards,
> Hari

Hi Hari,

Here is the error when I ran modprobe acpi with Laptop Acer
Aspire 1652

FATAL: Error inserting acpi_cpufreq
No such device


Créez votre adresse électronique prenom.nom@laposte.net
1 Go d'espace de stockage, anti-spam et anti-virus intégrés.

Reply to: