[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: wpasupplicant and ifplugd(?) issues in etch

Björn Lindström wrote:
OK, to start with, if I use an /etc/network/interfaces like this in my
up-to-date etch installation:

    auto lo
    iface lo inet loopback

    allow-hotplug eth2
    iface eth2 inet dhcp
        wireless-essid {ESSID}
        wireless-key1 {KEY}

where eth2 is my wifi ipw3945 device (on a Dell XPS M1210), the
wireless network comes up nicely when I boot up, and comes back on
after suspension to RAM.

Now, I would like this to work just as automatically in more than one
location, so I have installed wpasupplicant.

After following the instructions in
/usr/share/doc/wpasupplicant/README.modes.gz I've arrived at this
entry for eth2 in /etc/network/interfaces:

    iface eth2 inet manual
        wpa-driver wext
        wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
    iface {ESSID} inet dhcp
    iface default inet dhcp

and this for /etc/wpa_supplicant/wpa_supplicant.conf:


Now, the connection comes up when I reboot, but after a suspension
it's gone, and stays gone, even when I try to manually take eth2 up.
Also, if I just take eth2 down manually with 'ifdown eth2', it doesn't
come up again without a reboot.

I've also tried using ifplugd to take the device up and down, but
haven't managed to get it working at all. I guess it might not work
with the ipw3945 driver, given that it seems to be a bit quirky.
Do I even need ifplugd with that new "allow-hotplug" stuff?

As for the wpasupplicant stuff, I've tried anything I can think of,
includinng trying a couple of alternatives to wpaupplicant, but I'm
stuck, and would be grateful for any help, examples of your working
setups, or similar.


Try using wpa_action to restart any interfaces used by wpa_supplicant, that is the recommended tool.

Reply to: