[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [ltp] Illogical Wireless Difficulty

On 2/12/07, Alex Deucher <alexdeucher@gmail.com> wrote:
I've never been able to get wireless working satisfactorily on Linux
using the GUI tools.  works fine from the command line however (better
than windows in most cases).  try this (as root or with sudo, replace
eth0 with your wifi Ethernet device):

ifconfig eth0 up
iwlist eth0 scan

this should list the available wireless cells.  You may need to run it
several times. pick one you like and then set the interface to use it:

iwconfig eth0 essid "Net Name" ap xx:xx:xx:xx:xx:xx

use the essid and ap MAC address from the cell you want from the iwlist scan.
finally, if you want to use dhcp:

dhclient eth0

that should do it.  I don't know why none of the GUIs don't just wrap that.


You're right, I tried almost every gui wifi tools but none of them
works.  I just followed what you said and it works.  In fact before I
also tried using commands instead of GUI, it turned out that my
missing the option "ap" was crucial, although I don't understand why.

Anyway, thanks a lot!

Reply to: