[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Ethernet Network card RTL8101E does not work

Hi *,

I have bought a Toshiba Satellite M115 Laptop, and I'm getting lots of
problems with the  Ethernet Network card [ RTL8101E (Fast Ethernet
with PCI-Express interface)].

I have downloaded the driver from realtek.com.tw and I have followed
the steps which appear in README file:


<Linux device driver for Realtek Ethernet controllers>

This is the Linux device driver released for RealTek Ethernet
controllers, which are listed as following.
1. RTL8169S/SB/SC (Gigabit Ethernet with PCI interface)
2. RTL8168B (Gigabit Ethernet with PCI-Express interface)
3. RTL8101E (Fast Ethernet with PCI-Express interface)


- kernel source tree (supported versions 2.4.x or 2.6.x)
- compiler/binutils for kernel compilation

<Quick install with proper kernel settings>

Unpack the tarball :
tar vzxf r1000_vX.YZ.tgz

Change to the directory:
cd r1000_vX.YZ

If you are running the target kernel, then you should be
able to do :

make clean modules (as root or with sudo)
make install
depmod -a

<Force Link Status>

1. Force the link status when insert the driver.
If the user is in the path ~/r1000, the link status can be forced to
one of the 5 modes as following command.

#insmod ./src/r1000.ko speed=SPEED_MODE duplex=DUPLEX_MODE autoneg=NWAY_OPTION

SPEED_MODE = 1000 for 1000Mbps
= 100 for 100Mbps
= 10 for 10Mbps
DUPLEX_MODE = 0 for half-duplex
= 1 for full-duplex
NWAY_OPTION = 0 for auto-negotiation off
= 1 for auto-negotiation on
For example:
#insmod ./src/r1000.ko speed=100 duplex=0 autoneg=0
will force PHY to operate in 100Mpbs Half-duplex.

2. Force the link status by using ethtool.
a. Insert the driver first.
b. Make sure that ethtool exists in /sbin.
c. Force the link status as the following command.

#ethtool -s eth? speed SPEED_MODE duplex DUPLEX_MODE autoneg NWAY_OPTION

SPEED_MODE = 1000 for 1000Mbps
= 100 for 100Mbps
= 10 for 10Mbps
DUPLEX_MODE = half for half-duplex
= full for full-duplex
NWAY_OPTION = off for auto-negotiation off
= on for auto-negotiation on

<Advanced feature>

- Supports Jumbo Frame
- Hardware Tx/Rx flow control


The procedure that I show above was not  successful. Then I tried with
the steps from [1] which is almost the same, the only difference
between both is that in this case I had to change some lines into
src/r1000_n.c, then I compiled and it didn't work again :S

Now, I'm compiling a new kernel version ( because i read
maybe the problem would be solved using this kernel.

Have  you had that problem? Can someone help me?

Notes: I'm using Debian Testing (32 bits)

Thanks for reading,

[1]  http://dvm.zapto.org:3334/~david/guicms/html/articles/one.php?number=118

Muammar El Khatib.
Linux user: 403107.
Key fingerprint = 90B8 BFC4 4A75 B881 39A3  1440 30EB 403B 1270 29F1
http://muammarelkhatib.net | http://www.teorex.org
: :' :
`. `'

Reply to: