[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Suspend - no resume


I'm using suspend2 as well on my two debian laptops (lifebook p1510 and acer aspire 5021). I'm not using initrd at all with the setup, for obvious reasons: as I anyway had to roll your own kernel with suspend2 patches, it was much less trouble to compile enough stuff statically into the kernel than to start hacking the linuxrc in initrd to notice when to resume and when to just boot.

The basic idea is:
- compile all IDE/ATA bus related stuff into the kernel statically (so that the kernel can access your discs without loading the modules from the initrd)
- and filesystem support to mount your root filesystem, too
- and the suspend2 stuff as well

After that, just boot without initrd, with something like the following in your grub config:
title           2.6.16 -- no rd, resume
root            (hd0,0)
kernel /boot/vmlinuz-2.6.16 root=/dev/hda1 rw resume2=swap:/dev/hda5 noapic


Takis Diakoumis wrote:

i'm trying to get suspend2 working on my thinkpad r52. i'm using debian
etch with a vanilla kernel from kernel.org and custom config for this
particular laptop.

following the instructions from suspend2.net i recompiled my kernel with
suspend2 and installed hibernate etc. i modified hibernate.conf with
relevant options.
suspend itself seems to work ok. the machine begins to create the
restore image, i get the text progress bar etc and then it shuts down as
expected. however when i resume it goes through a normal boot process as
opposed to restoring its previous state.

i have tried it with suspend to disk using both swap and a file. the
result is exactly the same for both.

one thing that i'm unsure of is the creation of the initrd image.
everything i have read regarding this setup for debian is different. i
have tried the script from suspend2.net, and also the 2 (or 3) different
script from the same sites wiki at

the only suspend2 output i get with dmesg is as follows:
Suspend2 Core.
Suspend2 Compression Driver loading.
Suspend2 Encryption Driver loading.
Suspend2 Swap Writer loading.
Suspend2 FileWriter loading.

my grub boot options seem to be correct:
kernel  /vmlinuz- root=/dev/sda3
resume2=file:/dev/sda5:0xeac000 libata.atapi_enabled=1 ro vga=791
the above was my last stuffing around with a suspend file - again, have
tried suspend to swap with relevant changes made to the config and boot
stuff and the result is the same.

no errors are generated. i'm stumped and spent most of the day fiddling
with this.

some help would be most appreciated.


Ossi Väänänen ## ossi@kastema.to ## http://pupu.homeunix.org/
        - To iterate is human, to recurse, divine -

Reply to: