[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: No sound in xmms, on Dell Latitude D400, with Debian sarge r1.

Hi Amarendra,

Did you choose the 2.4 or 2.6 series kernel when installing Sarge?  With the 2.6 series kernel, ALSA comes along for the ride.

Since you're using Totem, I'm guessing that you're using GNOME as well, right?  If not, what desktop system are you using (KDE or basic window manager)?

A couple of things to try (assuming you're using GNOME):
1) run alsaconf from a terminal as root.
2) In GNOME's "Sound" preferences, are you starting the sound server or not?  Try both ways.
3) Make sure that your multimedia settings in GNOME's preferences menu and your XMMS settings line up with one another.


Amarendra Godbole wrote:

I tried playing a song using xmms, but no sound seems to come from the
notebook. It is a Dell Latitude D400, with Debian sarge r1.

The i810_audio module (for AC'97 audio controller) is loaded, and xmms
is using the OSS driver 1.2.10 as the output plugin. I tried changing
it to ALSA 1.2.10, but it did not work. Surprisingly, while I used the
Totem player to play a DVD, the sound was fine (could not run Totem to
play a song though, it ``quits unexpectedly").

The dmesg tells me:
i810_audio: Primary codec has ID 0
i810_audio: Audio Controller supports 6 channels.
i810_audio: Defaulting to base 2 channel mode.
i810_audio: Resetting connection 0
i810_audio: Connection 0 with codec id 0
i810_audio: AC'97 codec 0 supports AMAP, total channels = 2

lspci -vv tells me:
0000:00:1f.5 Multimedia audio controller: Intel Corp. 82801DB/DBL/DBM
(ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 01)
        Subsystem: Dell: Unknown device 0139
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium
TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 0
        Interrupt: pin B routed to IRQ 7
        Region 0: I/O ports at d800 [size=256]
        Region 1: I/O ports at dc40 [size=64]
        Region 2: Memory at faeff800 (32-bit, non-prefetchable) [size=512]
        Region 3: Memory at faeff400 (32-bit, non-prefetchable) [size=256]
        Capabilities: [50] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=375mA
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-

ANY pointers to enable the sound through xmms would be appreciated.
Shall be glad to furnish any more info. if needed. Thanks in advance!



Reply to: