[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Latest ipw2200 driver breaks when used with wpa_supplicant

On Wed, 29 Jun 2005 15:30:27 -0700
Joe Emenaker <joe@emenaker.com> wrote:

> After upgrading to the 1.0.4 driver (and to the 2.3 firmware) for the 
> ipw2200 in my Dell Inspiron, Kismet finally worked (yea!). However,
> when  I tried to enable WPA by switching from waproamd to
> wpa_supplicant, my  keyboard would lock up and I would see endless
> messages about "error  detected in firmware".
> In case anybody else runs into this problem, the solution (for me and 
> for several others on the ipw2200 bugzilla site) is to add
> "hwcrypto=0"  to the options when the module is loaded. Then, things
> seem to work again.
> The problem I'm having *now*, though, is that I can't seem to add this
> option. Here's what I tried:
>  o Created a file called /etc/modutils/ipw2200 with one line: "options
> ipw2200 hwcrypto=0" (without the quotes)
>  o Ran update-modules
>  o *Verified* that the line showed up in /etc/modules.conf
> Problem is, modprobe still isn't picking it up.
> The ipw2200 is currently being detected by "discover" (which uses
> plain  ol' modprobes to load modules). So, what I was finally reduced
> to doing  is changing discover's modprobe line from:
>   modprobe $MODULE ...
> to
>   if ( echo $MODULE | grep -q ipw2200 )
>   then
>     modprobe $MODULE hwcrypto=0
>   else
>     modprobe $MODULE ...
>   fi
> Naturally, I'd like to avoid using this kind of hack.
> Does anyone know why modprobe isn't picking up my options for this
> module?
> - Joe

As far as I know, once you put it into modprobe, you dont need discover
to find it. Put it in the blacklist of discover, and it will be loaded
with the real options you wanted it to be loaded. 

On a sidenote, I had discover and hotplug doing the discoveries at the
same time, and there is no need to have two hardware finder service, in
my opinion, so I disabled, and reinstalled discover all together.

But the blacklist should fix your problem.



Reply to: