[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Sarge on Presario 2200


So did I.
Woody installed successfully, and dist-upgrade completed fine, but it
doesn't solved the problem.
Well, without hotplug laptop boots successfully, but 
1) modprobe i810_audio still results in segfault
2) modprobe intel_agp hangs. I can switch to another console and run ps,
and I see modprobe in 'D' state (uninterruptable sleep).
Looks like booting with hotplug hangs because of this: it modprobes
intel_agp and remains frozen; because hotplug starts at single-user by
rcS, other virtual consoles aren't appeared yet.

On Thu, May 05, 2005 at 10:25:59PM +0530, Ritesh Raj Sarraf wrote:
> Hash: SHA1
> Alexander A. Vlasov wrote:
>> Hello, debian-laptop users.
>> Recently I received Compaq Presario 2200 laptop (2209CL) and tried to
>> install Debian Sarge, but I encountered one problem:
>> Installation finishes successfully, but after reboot laptop doesn't boot
>> properly. Last thing I see is
>> hotplug tries to modprobe i810_audio
>> i810_audio: has id 0, resetting connection 0, connection 0 with codec 0.
>> Codec 0 is softmodem, skipping.
>> unable to handle kernel NULL pointer dereference at virtual address
>> 00000024, printing eip deb2c1d2
>> *pde=00000000
>> Oops: 0000
>> ...registers, stack and call trace here...
>> ./pci.agent: line 156: 354 segfault $MODPROBE $MODULE > /dev/null 2>&1
>> i810_audio can't be loaded
>> missing kernel or user mode driver i810_audio
>> looks like booting continues, but after this I receive two lines about
>> successfull registering drivers usbdevfs abd hub and computer hangs.
>> No disk activity, nothing -- but keyboard is working, symbols I typing
>> appearing on the screen. But boot process doesn't continues.
>> This problem persists with both 2.6.8 and 2.4.27 kernels.
>> Ubuntu livecd boots soccessfuly (and audio works fine, btw).
>> Any ideas, any help would be greartly appreciated.
> I have a 2203AL model. I faced exactly the same problem. The way I fixed it
> was to do the base-install using woody and then upgrade to sarge and do the
> rest of the installation.
> But that was about 7 months back.
> Looks like I did a mistake not filing a bug report then :-(
> rrs
> - -- 
> Ritesh Raj Sarraf
> RESEARCHUT -- http://www.researchut.com
> Gnupg Key ID: 04F130BC
> "Stealing logic from one person is plagiarism, stealing from many is
> research."
> "Necessity is the mother of invention."
> Version: GnuPG v1.2.5 (GNU/Linux)
> iD8DBQFCelAf4Rhi6gTxMLwRAsdxAJ4lofhcrRd1oK1UrIey003hiQ1ruACgqnFv
> CRpbF9hr9MVMB3zLMN3A+s0=
> =48s0

 Alexander A. Vlasov
 Debian GNU/Linux user
 JID:                           zulu@jabber.ru
 nic-hdl:                       ZULU-UANIC

Reply to: