[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

wireless on Averatec rt2500 chipset

ok, I seem to be missing something...

Trying to install rt2500 drivers for a wireless nic on an Averatec 5500
running Debian Sarge

drivers from

following these directions

1) Plug in the card and check lspci to see that it is recognised (Listed as
Network controller: Ralink
2) Check uname -a to see which kernel version you are running
3) Install the kernel-headers package that exactly matches your kernel
(about 3MB)
4) Download and extract (tar -xzf) the ralink driver
5) cd to the Modules subdirectory
6) (For version 1.1 of the driver just make - no need for steps 6-8) cp
2.6.x/Makefile . (the supplied Makefile for the 1.0 driver is for 2.4.x)

I'm using 1.1, so I just need "make" which tells me:

"/lib/modules/2.4.27-speakup/build/Rules.make: No such file or directory
make: *** No rule to make target
'/lib/modules/2.4.27-speakup/build/Rules.make'. Stop.

There is no "build" folder for the Rules.make to be in...
I've tried an empty "Rules.make" file in a build dir I made, but it seems to
need some rules to be in the Rules file, go figure...
How do I find or make Rules.make?

I would greatly appreciate knowing what to do/try next. I have tried the
other steps on the directions page, as well as what ideas I could find
elsewhere, (such as the "empty. Rules.make file)

Reply to: