[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ACPI problems on AOpen 1557 laptop - solved

Le vendredi 18 février 2005 à 15:53 +0000, Yannick Warnier a écrit :
> Le vendredi 18 février 2005 à 14:43 +0000, Yannick Warnier a écrit :

OK well, still on this AOpen ACPI problem. What I've come to now is this

# /etc/acpi/sleep.sh
# Initiates a suspend to memory [when sleep button is pressed]

/sbin/ifdown eth0 &
/etc/init.d/mysql stop
/etc/init.d/hotplug stop
touch /tmp/suspended
rmmod b44
rmmod ipw2200
sleep 1

echo mem > /sys/power/state

sleep 1
  /etc/init.d/hotplug start
  /etc/init.d/mysql start &
  /sbin/ifup eth0 &
) 2>&1 | logger -t 'acpi-sleep' &

...which gets me almost everything working (as far as I can see) BUT the
network. Now I have tried almost everything, I think, and nothing

The last test I did was operate all operation manually (except for the
echo mem > /sys/power/state
and when I do this by hand, my network connection is recovered without
any problem.

But when I use the sleep button, there is no way it will give me my
network back (even ifdown eth0; rmmod b44; /etc/init.d/hotplug restart;
modprobe b44; ifup eth0; doesn't give anything but "Network is down")

Does anybody ever encountered a similar problem or could give me some
kind of way of thinking so that I could track it down?


Reply to: