[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Garmin GPS-18 connected by USB

I have recently purchased a GPS that I hoped would be portable and easy to use.

The Garmin GPS-18 is about the size of a 6' tape measure.

It is USB and gets its power from USB.

However, I cannot get gpsd to talk to it.  Because of that, the other
programs that work with the GPS (xgps, gpsman, gpsdrive) can't find it

Maybe I am not configuring something correclty.

Does anyone know how to set this up so it will work?

lsusb show:
Bus 001 Device 001: ID 0000:0000
Bus 001 Device 003: ID 091e:0003 Garmin International GPSmap 60C

But apparently I don't know how to configure gpsd to look at it.

dpkg-reconfigure gpsd tell me to use something like /dev/ttyUSB0.
I've tried that and I've tried /dev/ttyUSB1.

No joy.

I've seen some tools on sourceforge (garmin_gps), but they require a 2.6 kernel.
I've got: Linux 2.4.27-1-386 #1 Wed Dec 1 19:43:08 JST 2004 i686 GNU/Linux

Any suggestions?


Reply to: