[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Apt-get update killed i810 audio?

Thomas Hood wrote:
On Wed, 22 Dec 2004 10:10:14 +0100, Hanspeter Kunz wrote:

On Wed, 2004-12-22 at 12:52 +1000, Ben wrote:

Hi all,

Just wondering if anyone else has had this problem recently...

I'm running debian testing. did an apt-get update three days ago and now my sound doesn't work! dmesg doesn't show anything interesting, but i have noticed on boot when pci loads(?) that i810 is blacklisted

Yes it is. The reason is I guess that it interferes with the ALSA
drivers, which are prefered. If you want to continue using OSS just take
it out of the hotplug blacklist (in /etc/hotplug).

Hmm.. removed everything related to i810 in /etc/hotplug. module seems
to load On boot pci says i810 loaded successfully..) when KDE starts I
still get "no /dev/dsp" messages and no sound.

if I lsmod i810_audio is not loaded, so I insmod ac97_codec & i810_audio
everything now shows up in lsmod, but still no sound :(

The latest ALSA does blacklist all OSS modules.  The reason, of course,
is that OSS modules interfere with ALSA modules in that they try to
control the same hardware.

If you have alsa-base installed on your system and you are still using
OSS sound modules then you may experience loss of sound on upgrade to
the latest alsa-base release.  This is not a bug in alsa-base.  If you
want to use OSS modules then you should not have alsa/libasound packages

If you would like to resume using OSS modules then purge alsa* and

If you would like to begin using ALSA modules then most probably all you
need to do is load them.  Many people arrange to have this done
automatically at boot time either by installing the discover package or by
adding the name of the sound card driver module to /etc/modules.  (I am
not sure whether or not hotplug loads ALSA modules at boot time.)

At this stage I plan to carry on using OSS as I am happy with the way my
system is. AFAIK I am not using alsa but it is installed on my system.

So.. I went to console, typed apt-get remove alsa* and libasound*. apt
decided that one of the items it wanted to remove was kde, this doesn't
seem to be a good thing as I use KDE all the time..

should I be using apt to purge? if so can I just remove alsa-base and
alsa-utils to regain sound?

thanks for the hints so far,


Reply to: