[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

On going problem.

I have a ThinkPad 600E and am trying to setup pnp so I can turn off the IR
port and turn on com1 with out having to load into a dos/windows partition.
In the past I was given the following info and have done this but when I
type lspnp I get lspnp: /proc/bus/pnp not available

I am not sure what I have missed but it seems that PNP is still not
installed yet I have installed pcmcia-cs with pnp enabled so I am not sure
what I have missed.

Thanks Kris

>I have the same problem on a 600E-2645-4AU.
>The solution was to build pcmcia-cs with the -pnp option, so that
lspnp/setpnp worked. Then, I can use setpnp to change >these without having
to boot into Losedoze or DOS.
>I've also just pulled out the pnp-related files from pcmcia-cs, and built a
pnpbios.o module that just does the pnp stuff only, >o setpnp can work.
Haven't made a Debian package ofthis thing but if you want it let me know
and I can post it >smewhere.

Reply to: