[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Problem with kernel 2.4 on new laptop

I just got myself a new laptop (the old one died).  Its a Clevo D410E, with a 
Pentium IV and Ati 9000 graphics.

My first attempt to install was to use Knoppix, but as soon as it tried to 
load the kernel (a 2.4 kernel) it cleared the screen and stopped.

So I tried a Debian 3.0r1 CD, and installed that with a 2.2 kernel, and
it works.  It boots quite happily and I can run all my normal stuff
on it, provided I stick to stable.  Normally I run unstable on my laptops
as they generally work better and also I get KDE 3, OO, Eclipse etc.

So I tried upgrading to unstable, keeping the kernel, but I got into a
problem with upgrading libc6, it complained that sleep 1 and ldconfig
both caused illegal instrunction exceptions.  So I thought well maybe
there is something in this P IV that it does not like, and tried to upgrade
to a 2.4 kernel.  I tried 2.4.22, and it failed in exactly the same manner as

I select the 2.4 kernel from Lilo, and it unpacks the kernel, says that it is
now going to boot the kernel, it clears the screen and stops dead.  

So I thought well maybe this is an apic problem, and tried noapic, no change.

So I thought maybe this is a graphics problem, the Ati 9000 being 
relatively new.  So I tried video=vesa, and that made no difference.
So I then remembered I had had difficulties with video=vesa with 
some stock 2.4 kernels on another machine, and set up a serial
console.  I tested this on the 2.2 kernel, and then tried with the 2.4,
exactly nothing came our of the console.

I notice that in the 2.4.23 kernel there is a fix that provides a nolapic
parameter, but I do not know if that is even remotely relevant.

Does anyone have any ideas as to what might be the cause of the
problem, or how to proceed with debugging?

Thanks in advance


Reply to: