[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

laptop-net and ppp (woody on Dell I8600)

Greetings everyone,

I'm at an impasse: too many variables.  I've read the laptop-net manual very
carefully, twice, configured laptop-net per the manual, but I'm getting
erratic behavior.  First the general questions:

Does anyone have laptop-net working with ppp?  The manual does not mention
ppp at all.  I presume beat detection is not applicable to ppp via built-in
modem. This means that starting ppp (via pon/poff) has to somehow change the
scheme/profile.  Is the preferred way to call "laptop-net scheme whatever"
from pon/poff?  This brings up a potential conflict: what would laptop-net
do if ppp is started and the built-in Ethernet is still plugged in?
What I have observed is that the scheme is not changed, but this may be
because of any of the other problems I have at the moment.

My thought is that the preferred solution is to have an applet that would
allow quick modem control.  I have tried gpppon, but the off button doesn't
work: the ppp0 connection is not affected.  Using pon manually (as root)
works, but fails as a regular user.  The on button of gpppon works fine,
even as a regular user.  Of course, I've already changed a lot of file
access permissions to solve the easy problems, such as access to the ppp
config files, changed suid and sgid, etc...  Has anyone encountered this
type of problem in woody?  Or is it specific to this laptop?
Is anyone aware of another front-end applet that can control pon/poff,
preferably with 2,3 or 4 buttons right on the panel for one click ppp

The specific laptop-net (2.7-1, as comes with woody) problems I've encountered:

o Even though this is a brand new laptop and all recent laptops are supposed
  to have link beat detection on the net interface, this works only sometimes.
  Unplugging the cable results in a beep but nothing else happens.  When
  the laptop is booted with the cable in, the network interface doesn't work
  until I do an explicit "ifconfig eth0 192.168.x.x netmask up"
  The driver is loaded, it is also specified in /etc/defaults/laptop-net.
  Does anyone know if for some reason link beat detection is not supported in
  the bcm4400 driver?  I assume I shouldn't have to do a manual ifconfig,

o There is an error message when manually switching schemes after poff.  This
  seems to imply that laptop-net expects to kill/stop ppp itself.  Is this
  how people are starting/stopping ppp? just by changing scheme?  Running
  poff from a deselect file maybe?

o Manual scheme changes don't seem to affect the profiles.  When I change
  schemes manually, the profile doesn't change, so I'm regularly faced with
  "laptop-net scheme" reporting one scheme and "laptop-net profile" reporting
  another.  I have configured, per the manual, 3 schemes/profiles:

  home - 192.168.x.x address, built-in Ethernet (bcm4400/eth0)
  dialup - the only variable in /etc/laptop-net/schemes is INTERFACE=ppp0
  offline - no variables, just as in the manual
  *) the last case, DHCP=yes for those cases where I plug into another net

  I have configured some IP addresses of the home network in ip-map, but
  since the link doesn't come up automatically, it's no surprise they are
  not seen.  In the .../profiles/dialup/files.d/patterns I have the ISP's
  addresses (just the first number as that is what stays constant) and in
  .../profiles/home/files.d/patterns I have the home lan pattern.

  Another issue is that having to become root (or do a sudo) to change schemes
  is a pain in the butt.  I have already given up having another scheme or
  sub-scheme for connectiong to the home net via a pcmcia 3c589 ethernet card.

o Another item that doesn't work is the execution of the before-select and
  deselect files.  These files (for the dialup scheme) contain iptables rules
  to make a nothing-from-outside-gets-in firewall and a return to no firewall.
  Manual execution of these scripts works as expected.

o Are people using diald in combination with laptop-net?  I have avoided
  messing with diald.  Actually I have disabled it since it attempted to
  start ppp0 right after booting.

o I have also tried the copying of files feature of laptop-net with one file.
  (~/.kde/share/config/kioslaverc) since this file contains the ProxyType=1|0
  variable (use proxy or not) which is one item I need adjusted: at home the
  laptop is behind an http proxy and when in dialup mode the iptables firewall
  handles security.  No surprise that the copying of this file doesn't work
  either.  Probably for the same reason that the profile doesn't change when
  the scheme does.

One other thing I've noticed: when the modem (a PCTEL soft modem) is
accessed directly through minicom, it reports CONNECT and the speed of
connection, but chat only reports (in /var/log/messages) CONNECT and no speed.
Chat is being called with the -v flag.  In my home firewall machine, running
an old Red Hat) the speed is reported by chat.

Has anyone encountered these problems?  I can provide more info if needed.
This has already become much longer than I intended.  I would very much
appreciate any hints, suggestions or comments.



Reply to: