[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Debian on ACER TM 290 - X screen problem


  it seems that I'm the only one in the world, with
access to the Net, that's not able make X work with
the Intel 810 graphics chip on board of the Acer
Travelmate 290. I'm beginning to feel stupid. :-/

  I've problems with the modem too, but other hardware
(sound card, eth card and external floppy disk drive)
works fine.

  I've found some pages [1] but I've followed the
advices with no luck.

  I'm using Debian 3.0 (stable), with X packages
downloaded in the last 15 days from debian.org.
Kernel 2.4.22.

  I've rebuilt the Linux kernel with the configuration
in [2] (ACPI, agpgart, DRM, i810-i830), and configured
X with:

	# dpkg-reconfigure xserver-xfree86

and the result is in [3]. The Device section is:

	Driver "i810"
	BusIS "PCI:00:02:00"
	VideoRam 65536

  When running "startx" I see the screen going blank
like on normal X startup, but then the console is
back and I see the error:

(II) I810: Driver for Intel i810 chipset: i810, \
i810-dc100, i819e, i815
(WW) I810: No matching Device section for instance \
(BusID PCI:0:2:1) found
(EE) No devices detected.

Fatal server error:
no screens found

if I change "PCI:0:02:00" to "PCI:00:02:01" the error

...No matching Device section for instance \
(BusId PCI:0:2:0)  

it is trying to humiliate me... :(

  The output of "lspci" is:

00:02.0 VGA compatible controller: Intel Corp.: \
Unknown device 3584 (rev 02)
00:02.1 Display controller: Intep Corp.: \
Unknown device 3582 (rev 02)

and I guess that the controller of the LCD screen is
the 02.0 one.

  I was not able to make xserver-vga16 work either,
I always get errors for unsupported video modes.

  This is not Debian-specific, but I hope that someone
can help me. Thank You in advance.


[1] For example:



Yahoo! Mail: 6MB di spazio gratuito, 30MB per i tuoi allegati, l'antivirus, il filtro Anti-spam

Reply to: