[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: sound on a Thinkpad T40 - new info

Note that I have no particular knowledge of the T40.

On Mon, Sep 15, 2003 at 07:29:31PM +0200, Martin Wegmann wrote:
> On Monday 15 September 2003 16:23, Martin Wegmann wrote:
> > (unknown) wrote:
> > > /etc/modutils/alsa has 'alias snd-card-0 snd-intel8x0'.
> >
> > anyway - I haven't tried so much yet. only
> > /etc/init.d/alsa-autoconfig as root and then I stopped because of the error
> > message
> > when looking at /etc/modutils/alsa it is empty. does that mean I haven't
> > configured the soundcard or installed some modules?

I'd suggest getting the sound to work by hand before using the init
scripts. I.e. (for ALSA, assuming the information posted above is

# modprobe snd-intel8x0

Then try running alsamixer to unmute the soundcard, and play a wav
with aplay. Once that works, try to get ALSA set up correctly (start
with /usr/share/doc/alsa-base/README.Debian).

> Sound server informational message:
> Error while initializing the sound driver:
> device /dev/dsp can't be opened (Permission denied)
> The sound server will continue, using the null output device.

To give a user permission to use audio, it should normally suffice to
add him to the group 'audio'. Note that /dev/dsp is an OSS device
(ALSA emulates it via snd-pcm-oss), so that may pose additional

> additionally I ran sndconfig (0.7) to configure my soundcard but did not 
> suceed.

According to the package description, sndconfig is OSS-specific, so
you most likely don't want to use that.


Reply to: