[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ATI M9 DRM issues,

If I were in your shoes, i'd try copimliy agpgart as a module and then you can 
modprobe with the agp_try_unsupported=1 paramater.  I've never had good luck 
getting the framebuffer working correctly, so I compile w/o fb support. Also, 
I do remember running into a bug that if I booted into a higher-than-basic 
resoultion  (vga=XXX @ the lilo prompt), I could never get X to start. It 
always seemed like it could switch modes properly.

On Thursday 04 September 2003 16:53, Aaron Van Couwenberghe wrote:
> On Thu, 2003-09-04 at 10:58, Jordan Lederman wrote:
> > I just replied to someone else about the radeon M9, see if what I wrote
> > helps you, and if not, drop me a line.
> > 		--jordan
> Well, I wasn't using the 3d accelerated 'radeon' driver but the merely
> 2d 'ati' driver - but switching doesn't seem to have helped.
> I tried with the latest DRI CVS snap, and with daniel's source package.
> Coincidentally his source tree is too old for the radeon driver to even
> load :P (need 1.9 or >). So I'm using, radeon-20030901-linux.i386.tar.
> Now, my framebuffer resizes correctly when i leave X (one good thing at
> least!) but I get the following output from the radeon driver:
> (II) RADEON(0): Direct rendering enabled
> (==) RandR enabled
> (II) Initializing built-in extension MIT-SHM
> (II) Initializing built-in extension XInputExtension
> (II) Initializing built-in extension XTEST
> (II) Initializing built-in extension XKEYBOARD
> (II) Initializing built-in extension LBX
> (II) Initializing built-in extension XC-APPGROUP
> (II) Initializing built-in extension SECURITY
> (II) Initializing built-in extension XINERAMA
> (II) Initializing built-in extension XFree86-Bigfont
> (II) Initializing built-in extension RENDER
> (II) Initializing built-in extension RANDR
> (EE) RADEON(0): FBIOPAN_DISPLAY: Invalid argument
> Oops. X says Direct rendering enabled. But then I get an error, and
> glxinfo says:
> direct rendering: No
> lspci says:
> 00:01.0 PCI bridge: Silicon Integrated Systems [SiS] 5591/5592 AGP
> 01:00.0 VGA compatible controller: ATI Technologies Inc: Unknown device
> 4c66 (rev 01)
> (vga chipset is LF according to X)
> so where I'm going now is that Linux 2.4.22 has no AGP support for the
> 5591/5592 agp2x chipsets yet, but I am almost certain you can still get
> accel even without specific chipset support.
> If the whole server log would be useful I'd be happy to send it
> privately but I think I've spammed the list enough for one day.
>    --aaron

Reply to: