[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Need help configuring wlan - Belkin F5D6020Y PC-card

Hi everyone,

I am running "sid" and have a netgear ME102 access point connected to my nework hub. My network does not use dhcp, all ipadresses are static adresses. The ME102 works fine with the Belkin F5D6020Y PC-card when connecting via a windows laptop, so the configuration for the ME102 Accesspoint is correct and functioning (it has been assigned essid = wireless).

The network looks like this. Server (which is also the gateway), the accesspoint has and the laptop has The laptop has a built in ethernet card (ee100pro) which is assigned eth0.

Below is some info from syslog, iwconfig, cardctl etc. After the info you can find my questions.

iwconfig eth1 gives the following output:
IEEE 802.11-DS ESSID:"" Nickname:"Prism I"
Mode:Managed Frequency:2,462GHz Access Point: 00:00:00:00:00:00
Bit Rate:11Mb/s  Tx-Power=15 dbm  Sensitivity: 1/3
Retry min limit:8 RTS thr:off Fragment thr:off Power Management: off
Link Quality: 0/92 SIgnal level: 134/153 Noise level: 134/153
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessiv retries:0 Invalid misc:0 Missed beacon:0

cardctl ident outputs the following;
Socket 1:
product info: "Belkin", "11Mbps Wireless Notebook Network Adapter", "Version 01.02", ""
manfid: 0x0156, 0x0002
function: 6 (network)

var/log/dmesg doesnt show any relevant info, however var/log/syslog shows the following;

cardmgr[245]: error in file 'config' line 1231: unknown device 'pcmf504'
cardmgr[245]:watching 2 sockets
cardmgr[246]: starting version is 3.2.2
cardmgr[246]: socket 1: Intersil Prism2 11 Mbps Wireless Adapter
cardmgr[246]: executing: 'modprobe orinoco_cs'
kernel: hermes.c: 16 jan 2002 David Gibson
kernel: orinoco.c 0.09b
kernel: orinoco_cs.c 0.09b
kernel: eth1: station identity 001f:0003:0000:0008
kernel: eth1: Looks like an Intersil firmware version 0.08
kernel: eth1: Ad-hoc demo mode supported
kernel: eth1: IEEE standard IBSS ad-hoc mode supported
kernel: eth1: WEP supported, 104-bit key
kernel: eth1: MAC adress "gives correct MAC-adress here - my note"
kernel: eth1: Station name "Prism I"
kernel: eth1: ready
kernel: eth1: index 0x01: Vcc 5.0, irq 3, io 0x0100-0x013f
cardmgr[246]: executing: './network start eth1'
cardmagr[246]: + /sbin/ifup: interface eth1 already configured

If i try to do iwconfig eth1 ap any i receive the following error
Error for wireless request "Set AP Adress" (8B14) :
SET failed on device eth1 ; Operation not permitted.

and finally ifconfig eth1 gives the following;

Link encap: Ethernet HWadrr "correct adress- my note"
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100 RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:3 Base adress:0x100


1) The primary question - how do i get it to work with my accesspoint?
2) What is "Intersil firmware" and why does kernel report "Station name Prism I"? DOes this mean my card is communicating with another accesspoint than my own? 3) I have noted when googling that Belkin F5D6020u has a Atmel AT76C502?A chipset and that they recommend AtmelWLANDriver project..i gave it a shot but to no avail, although i think i goofed the install. Can someone help explain how debian handles pcmcia, i have noticed there are files in both /etc/network and /etc/pcmcia that seem relevant. I have tried to get my system to use another driver than orinoco but to no avail, which suggests that i am not making changes in the correct place. 4) when i first tried to connect to the access point i once succeeded in getting the card to register with my access point, but i have never been able to get it to do again - see the results of iwconfig eth1 ap any - i'm guessing that its an encryption problem and i have not quite been able to figure out how to set encryption. Yes i know the command suggested by iwconfig man but it doesnt seem to help.
5) Arrrrgghhhh i'm going mad - what can i do?
6) while your at it - what is the meaning of life?.

Anyway, thanks for taking time to read this, any responses can be sent directly to me.


PS/ i did send a short, very much shorter post to the swedish list - but it did not get any usable results. SInce this is an entirely new mail with much more content i dont think its a cross-post.

Reply to: