[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: CD-reader on SONY VAIO SR27K

"blair" == blair kelly <blair.kelly@att.net> writes:

blair> Does anyone have an idea what the message that I get in
blair> /etc/syslog when I insert the PCMCIA card for the CD-reader
blair> means:

blair> : cardmgs[339]: get dev info on socket 0 failed: Resource
blair> temporarily unavailable

Shyamal Prasad <shyamal.prasad@sbcglobal.net> suggested:

Shyamal> On my Sony VAIO N505VE I had to (config.opts)
Shyamal> exclude irq5
Shyamal> exclude irq7
Shyamal> exclude irq9
Shyamal> and also (/etc/pcmcia or ????)
Shyamal> PCIC_OPTS="irq_list=10,11 has_ring=0"
Shyamal> to get my PCMCIA driver to work. On the CD-ROM I had to set it to boot
Shyamal> mode "boot" as opposed to "cardbus" but you probably already knew
Shyamal> that.
Shyamal> See if this helps....this is all with the i82365 driver, but the same
Shyamal> files worked with yenta socket as far as I remember. I'm sorry I am
Shyamal> not able to lookup my laptop right now, this if from notes I have. If
Shyamal> you need more information just ask.

I tried the suggestion Shyamal, but nothing seemed to change.

I have done some more looking around and have found that
/etc/pcmcia/config contains

: card "Ninja ATA"
:   version " ", "NinjaATA-"
:   bind "ide_cs"

which explains why I keep seeing "ide_cs" when I insert the
card for the Sony PCGA-CD51 CD-ROM drive.

If I do /etc/init.d/pcmcia restart, I see

: cardmgr[990]: executing: 'modprobe -r ide_cs'
: cardmgr[990]: exiting
: kernel: unloading PCMCIA Card Services
: kernel: Linux PCMCIA Card Services 3.1.34
: kernel:   kernel build: 2.4.18-686 unknown
: kernel:   options:  [pci] [cardbus] [apm]
: kernel: Intel ISA/PCI/CardBus PCIC probe:
: kernel: PCI: Found IRQ 9 for device 00:0c.0
: kernel: PCI: Sharing IRQ 9 with 00:0a.0
: kernel:   Ricoh RL5C475 rev 80 PCI-to-CardBus at slot 00:0c, mem 0x10000000
: kernel:     host opts [0]: [isa irq] [io 3/6/1] [mem 3/6/1] [pci irq 9] [lat 168/176] [bus 2/5]
: kernel:     ISA irqs (default) = 3,4,5,7,10,11,12,15 PCI status changes
: cardmgr[1055]: starting, version is 3.1.33
: cardmgr[1055]: watching 1 sockets
: cardmgr[1055]: Card Services release does not match

And then when I insert the card:

: kernel: cs: memory probe 0xa0000000-0xa0ffffff: clean.
: cardmgr[990]: socket 0: Ninja ATA
: cardmgr[990]: executing: 'modprobe ide_cs'
: cardmgr[990]: get dev info on socket 0 failed: Resource temporarily unavailable

As I said nothing changes if I follow the suggestions of Shyamal.

Other suggestions, please?


Reply to: