[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

alsa/sound/kernel-modules on thinkpad

Dear all

Thanks for all comments.

I have indeed been running bf24 all this time.  I hadn't been updating LILO
during kernel installation.  The reason for this omission is that the
dpkg -i dialogs didn't seem to be giving me an option to avoid installing
lilo into the MBR (I have another OS hogging the MBR).  I ran through it all
again and found I could install the boot block on the linux partition
(/dev/hda3).  So now uname and I are in agreement, and there is a new set of
error messages:

* During dpkg -i kernel-image-2.4.18_forAlsa.1.0_i386.deb I got this new
depmod error:

depmod: *** Unresolved symbols in /lib/modules/2.4.18/alsa/snd-intel8x0.o
There was a problem running depmod.  This may be benign,
(You may have versioned symbol names, for instance).
Or this could be an error. In any case, since depmod is
run at install time, we could just defer running depmod
Would you like to abort now? [Yes] no

* During the following reboot a lot of 'couldn't locate module X' messages
scrolled past, and after logging on lsmod brought me:

debian:~# lsmod
Module                  Size  Used by    Not tainted

I should have (at least?) one module, as I configured sound support to be
modular.  I decided to mess about with modprobe (the four modules I probe
are taken from the alsa-project doc page for my sound card):

debian:~# modprobe snd-intel8x0
/lib/modules/2.4.18/alsa/snd-intel8x0.o: unresolved symbol
/lib/modules/2.4.18/alsa/snd-intel8x0.o: insmod
/lib/modules/2.4.18/alsa/snd-intel8x0.o failed
/lib/modules/2.4.18/alsa/snd-intel8x0.o: insmod snd-intel8x0 failed
debian:~# modprobe snd-pcm-oss
debian:~# modprobe snd-mixer-oss
debian:~# modprobe snd-seq-oss
debian:~# lsmod
Module                  Size  Used by    Not tainted
snd-seq-oss            23424   0  (unused)
snd-seq-midi-event      2792   0  [snd-seq-oss]
snd-seq                33100   2  [snd-seq-oss snd-seq-midi-event]
snd-seq-device          3888   0  [snd-seq-oss snd-seq]
snd-pcm-oss            34656   0  (unused)
snd-pcm                47008   0  [snd-pcm-oss]
snd-timer               9152   0  [snd-seq snd-pcm]
snd-mixer-oss           8576   0  [snd-pcm-oss]
snd                    23688   0  [snd-seq-oss snd-seq-midi-event snd-seq
snd-seq-device snd-pcm-oss snd-pcm snd-timer snd-mixer-oss]
soundcore               3492   2  [snd]

* Intel 810 + AC97 Audio no longer in boot messages.  Interestingly, with
the new kernel, these old sound card messages no longer appear when booting

Aug 10 20:00:52 debian kernel: Intel 810 + AC97 Audio, version 0.21,
10:28:09 Apr 14 2002
Aug 10 20:00:52 debian kernel: PCI: Found IRQ 11 for device 00:1f.5
Aug 10 20:00:52 debian kernel: PCI: Sharing IRQ 11 with 00:1f.3
Aug 10 20:00:52 debian kernel: PCI: Sharing IRQ 11 with 00:1f.6
Aug 10 20:00:52 debian kernel: PCI: Sharing IRQ 11 with 02:00.1
Aug 10 20:00:52 debian kernel: PCI: Setting latency timer of device 00:1f.5
to 64
Aug 10 20:00:52 debian kernel: i810: Intel ICH3 found at IO 0x18c0 and
0x1c00, IRQ 11
Aug 10 20:00:52 debian kernel: i810_audio: Audio Controller supports 6
Aug 10 20:00:52 debian kernel: ac97_codec: AC97 Audio codec, id:
0x4144:0x5348 (Analog Devices AD1881A)
Aug 10 20:00:52 debian kernel: i810_audio: AC'97 codec 0 Unable to map
surround DAC's (or DAC's not present), total channels = 2
Aug 10 20:00:52 debian kernel: ac97_codec: AC97 Modem codec, id:
0x5349:0x4c27 (Unknown)
Aug 10 20:00:52 debian kernel: i810_audio: timed out waiting for codec 1
analog ready.
Aug 10 20:00:54 debian lpd[392]: restarted

* To get some more info I tried a few alsa commands:

debian:~# alsactl store
/usr/sbin/alsactl-0.9: save_state:963: No soundcards found...
debian:~# amixer
amixer: Mixer attach default error: No such file or directory

So I feel I've moved forward: I'm now correctly installing the new kernel
and the alsa error messags have narrowed in scope.  The remaining/new issues

* Not all of the messages that scroll past on bootup are saved in
/var/log/messages - specifically the 'can't locate module' messages.  Are
these other messags saved somewhere else?  Is it something like stoud >
/var/log/messages and stderr > /some/where/else?  Why am I getting a pile of
new 'can't locate module' errors?

* Where has this unresolved symbols problem with snd-intel8x0.o come from
and why?  I've never had that error message before.  This might be a good
one to solve.

* Presumably those intel810 boot messages no longer come up because I've
deselected the i810_audio module in favour of alsa.  Also presumably
alsactl's problems finding a card are nothing to do with this, but to do
with the depmod problems with alsa's own snd-intel8x0.  Is that the case?
What would happen if I had the built-in module(s) (e.g. intel ICH - any
others?) *as well* as alsa?  What about removing alsa altogether and going
with the kernel's built-in modules? (but, that not working was why I went
for alsa in the first place ...).

As before, all comments welcome.  When this is all over, I'll post a
commemorative web-page somewhere.

Best wishes


Reply to: