[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Can't boot from hd after upgrade to woody

Platform: DECpc 450SLC/e (laptop w/486, 8MB RAM, 250MB HD)

This machine got potato installed from floppies last year.  Yesterday
I started it, and it booted nicely from hd with the
kernel-image-2.2.19pre17-compact kernel from a potato floppy install.

I tried upgrading it to woody by editing /etc/network/interfaces to
get an eth0 card which would get its address from DHCP, inserting a
PCMCIA network card, editing sources.list, and doing
	apt-get update
	apt-get dist-upgrade

Everything seemed to run smoothly after the upgrade, but when I tried
rebooting it, it wouldn't boot from the hd.  It just prints out a lot
of "." characters, and the display then went blank, and the machine
was hanging indefinately.

It will boot from a potato rescue floppy with
	rescue root=/dev/hda1

I have examined the lilo.conf file, and checked the symlinks from / to
the kernel in /boot.  They look OK, as far as I can tell.

I have tried rerunning lilo, followed by rebooting, but the
behaviour was unchanged.

I have tried installing kernel-image-2.2.20-compact kernel from
woody.  This time the screen went full of "." characters, and then the
machine was hanging indefinately.

Is this caused by a LILO upgrade and incompatibilities with old

Could this be caused by LILO incompatibilities with a potato kernel? 

Could this be caused by the small amount of RAM on this machine?
The fact that the rescue floppy boots would seem to point in this
direction.  On the other hand, the machine booted from hd before the

All guesses, hints, and clues appreciated!


- Steinar

Reply to: