[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

alsa/sound on thinkpad

Dear All

Thanks for comments.  However, sound still not working.

Nate Bargmann wrote:
"This might be one of those instances where you just go ahead and compile
the ALSA modules from source against your 2.4.18 kernel, which I have
done here.  In the kernel config you must compile sound support as a
module, but do not enable any other sound drivers.  In other words, if
you do a make menuconfig, select sound support as <M> module and leave
all other sound selections blank."

I recompiled the kernel and compiled alsa from source, as per this
suggestion and the instructions in the respective packages.  The resulting
alsa-modules required alsa-base before it would install, so I installed
that.  After a reboot I ran alsactl, to un-mute the mixer channels.  Alsactl
failed with the error message, "No ALSA drivers installed."  As I thought
I'd just installed Alsa, I am at a loss again.  Do you install the drivers
separately from installing the modules?

Running alsaconf failed with the same messages as before (can't locate
module snd; No ALSA driver installed; etc.).  Why is it looking for module
snd?  Would it help if I could tell it to look for module 'sound' - how
would I do that?

Here are some relevant-looking lines from /var/log/messages of a recent

Aug  6 12:46:40 debian kernel: Intel 810 + AC97 Audio, version 0.21,
10:28:09 Apr 14 2002
Aug  6 12:46:40 debian kernel: i810: Intel ICH3 found at IO 0x18c0 and
0x1c00, IRQ 11
Aug  6 12:46:40 debian kernel: i810_audio: Audio Controller supports 6
Aug  6 12:46:40 debian kernel: ac97_codec: AC97 Audio codec, id:
0x4144:0x5348 (Analog Devices AD1881A)
Aug  6 12:46:40 debian kernel: i810_audio: AC'97 codec 0 Unable to map
surround DAC's (or DAC's not present), total channels = 2
Aug  6 12:46:40 debian kernel: ac97_codec: AC97 Modem codec, id:
0x5349:0x4c27 (Unknown)
Aug  6 12:46:40 debian kernel: i810_audio: timed out waiting for codec 1
analog ready.
Aug  6 12:46:43 debian lpd[366]: restarted

Matto Fransen wrote:
"kudzu added the following in my modules.conf:

alias sound-slot-0 i810_audio
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null
2>&1 || :
options sound dmabuf=1
alias synth0 opl3
options opl3 io=0x388
options cs4232 isapnp=1
alias eth0 eepro100
alias sound-slot-2 ad1848
post-install sound-slot-2 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null
2>&1 || :
pre-remove sound-slot-2 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null
2>&1 || :"

Alas, kudzu added only the following to my modules.conf:

### update-modules: start processing /etc/modutils/kudzu
alias sound-slot-0 i810_audio
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null
2>&1 || :
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null
2>&1 || :

### update-modules: end processing /etc/modutils/kudzu

This looks like a good lead, but unfortunately I don't quite know how to
make use of it. 'man modules.conf' is not enough!

So - I thought I'd installed alsa from source but some crucial step seems to
have been missed - don't know what.  Also module configuration is quite
different from that of a known-working similar machine - don't know how to
fix that either.

Sorry I haven't got clear questions this time: any clues or prompts for more
info will be gratefully received and acted upon.

I should say I'm not as newbie as I probably sound.  I've been using Linux
for a few years now but ,after a brief stint on Caldera OpenLinux 2.4 I've
been using SuSE since 6.4.  I decided to switch to Debian when I realised
that SuSE's 'user-friendliness' was allowing me to understand less and less
of what was actually going on.  This just felt bad, and it was removing one
of the main things attracting me to free software in the first place.
However, I am clearly still in the process of weaning myself off the GUI and
the nanny distro.

Best wishes


Reply to: