[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Xircom CardBus and Kernel 2.4

On Sunday 12 May 2002 21:47, you wrote:
> Marc.Duerner@student.shu.ac.uk writes:
>  > On Sunday 12 May 2002 02:33, you wrote:
>  > > I'm a Debian newbie who just installed Potato on my laptop, a Dell
>  > > Inspiron 7500.  I have a Xircom CardBus Ethernet 10/100 + Modem 56 PCI
>  > > card.  This card worked fine when I was using Red Hat 7.1 (kernel
>  > > 2.4.x) and also worked OK with the default 2.2 kernel that comes with
>  > > Potato.  I upgraded the distribution, then, finally upgraded to kernel
>  > > 2.4.18.  Now I can't get the card to work.
>  > >
>  > > Judging from the messages during boot, I'd say the new kernel isn't
>  > > recognizing my i82365 controller.  modconf confrims that this module
>  > > is not loaded and when I attempt to insert it, the installation fails.
>  >
>  > This is a well known problem. I also have a i82365 controller, but the
>  > i82365 kernel module doesn't work. The solution is to use the
>  > undocumented yenta_socket. Goto your /etc/default/pcmcia and set:
>  >
>  > PCIC=yenta_socket
>  >
>  > leave the rest as it is. Now restart your card services with
>  >
>  > /etc/init.d/pcmcia restart
>  >
>  > and tell us what happens.
> Well, its partly fixed.  The yenta socket module loads and the card is
> recognized as a Xircom card.  Unfortunately, the card doesn't work,
> now.  That is, the ethernet connection is never established and I
> can't ping any other machines.  I actually tried rebooting just to
> make sure I'm reinitializing everything but got the same result.
> I noticed during the boot that there's an error when the xircom_cb
> module loads now.  I can't seem to find the error message in any of
> the log files or I'd post it.  I notcied that the xircom module tries
> to load before the yenta module and thought this might be the problem
> but modconf shows the module as being loaded and reloading it and
> trying /etc/pcmcia/network stop/start doesn't help.

How did you setup your ethernet card? Have you edited 
/etc/pcmcia/network.opts or /etc/network/interfaces? Can you ping your own IP?

The yenta_socket should get loaded before the other modules. Try to find out 
about that error message. When you boot to the console login, you can scroll 
upwards with Shift+PageUp. Or try /var/log/kern.log Try to attach the part 
about the pcmcia modules to your mext email.


To UNSUBSCRIBE, email to debian-laptop-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: