[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: debian 3 upgrade lost PATH

On Mon, Feb 25, 2002 at 10:16:28AM +1030, Mike Carter wrote:
> Hello team,
> I sent the following to Brian Mays,
> Hi Brian,
> for some reason I have lost the path in my upgrade.  I thought it 
> would be a safe upgrade to go from stable to testing so I did and 
> now I have no X, no pcmcia, etcetra.  Dselect said that PATH 
> wasn't showing usr/local /usr/bin/ usr/sbin etcetra. to be able to 
> maintain this computers operability I used mc to find lilo and ran it 
> to make sure it configured.  Now I am writing to you on the same 
> machine with win98. Would you please tell me where to write it.  
> So I can go back to my debian 3.  


> I added usr/local/bin and the rest to profile.  They were already 
> present in login.defs and it unfortunately has made no difference.
> Yesterday I downloaded 200 meg of files for the upgrade and it 
> appeared dselect installed everything.  However  looking today 
> dselect sees the installed versions are the old ones. But I watched 
> them all get upgraded yesterday.  X cannot find what it needs 
> dselect cannot find what it needs install info etcetra.  I want to 
> maintain this upgrade somehow but now have no idea how.

We need to know more about what actually is happening.  'X cannot find what
it needs' and 'deselect cannot find what it needs' do not really help us.
What kind of errors are you getting?

Also, have you tried 'echo $PATH'? That will tell you what your PATH
actually is, which would help in trying to figure out what your problem is.

Have you tried using apt-get instead of dselect?
David Roundy

Reply to: