[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: 2.4.17 kernel & pcmcia problem

Brian Mays wrote:

Tom Allison <tallison1@twmi.rr.com> wrote:

But I built my own pcmcia-modules package and kernel-image package
from the 2.4.17 kernel-source and 3.1.36 pcmcia-source.  You mean that
these are still building bad links?

Not the pcmcia source.  The kernel source is building the bad links,
and there has not been a new release of this package since this problem
was discovered.  Therefore, there has not been an opportunity to fix the
problem with the kernel packages.

I have tried using the --force-overwrite option when installating
the pcmcia-modules package and it still does not work.  I am able to
get past the problem with the pcmcia-core problem.  But the specific
drivers I am using (orinoco, orinoco_cs) are still failing to modprobe

The temporary fix (until version 3.1.36-7 can be installed) is
to copy the etc/config file from the pcmcia-cs source (i.e.,
/usr/src/modules/pcmcia/etc/config in the pcmcia-source package) to
/etc/pcmcia/config.  That should fix your problem for now.

Your current config (assuming that you are running version 3.1.36-6
of pcmcia-cs) is set up to use the kernel drivers, not the standalone
drivers.  (This has been changed in 3.1.36-7.)  Since you are building
the pcmcia modules from the pcmcia-cs source, you want to use the
standalone drivers.

- Brian

QUESTION: If I were to use the kernel from ftp.kernel.org and then run a make-kpkg, would I see this same problem?

Also, I didn't see 3.1.36-7 in testing, yet. So I have gone ahead and tried your suggestion of copying the config file over.

It works.

What I was seeing is that I would get a successful load and the characteristic two Beeps. But then my log will fill up with Tx Errors as I tried to ping my gateway.

Thank you very much!

Reply to: