[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Sound on Thinkpad 770E

Thanks for your reply. :)  Here's what I get after adding that to
/etc/modutils/sndconfig, running update-modules and modprobe'ing cs4232:

/lib/modules/2.4.17/kernel/drivers/sound/cs4232.o: init_module: No such
Hint: insmod errors can be caused by incorrect module parameters,
including invalid IO or IRQ parameters
/lib/modules/2.4.17/kernel/drivers/sound/cs4232.o: insmod
/lib/modules/2.4.17/kernel/drivers/sound/cs4232.o failed
/lib/modules/2.4.17/kernel/drivers/sound/cs4232.o: insmod cs4232 failed

Is your sound card listed in /proc/pci or pnpdump?  I guess, as a last
effort, I could ghost an image of my current install, install some other
OS to get the info on the sound card (and make sure it's functioning
correctly) then restore Debian.  Is it normal for the sound card to not
be listed anywhere in /proc?  Thanks!

On Sat, 2002-02-09 at 07:31, Stefano Canepa wrote:
> I have a ThinkPad 380Z with cs4232 driver working. Here is my
> /etc/modutils:
> stetp:/etc/modutils# more sndconfig 
> alias sound-slot-0 cs4232
> options sound dmabuf=1
> alias midi opl3
> options opl3 io=0x388
> options cs4232 io=0x530 irq=5 dma=1 dma2=0 mpuio=0x330 mpuirq=9
> stetp:/etc/modutils# 
> Hope this helps.
> Stefano
> -- 
> Stefano Canepa e-mail: sc@linux.it
> To follow the path: look at the master, follow the master, walk with the
> master, see trough the master, become the master.

Reply to: