[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RE: Xircom hangs on a Tecra 8000

Thanks for your reply, Cassandra !

I am using ACPI v9.3. Putting in auto-select mode doesn't work under windows
nor linux. I am using kernel 2.2.19 that I recompiled to add APM and some
other features (sharing irq and stuff).

My NIC is a Xircom RBEM56G-100 (CardBus Ethernet 10/100+Modem 56).

So, any clue ? 


-----Original Message-----
From: Cassandra Ludwig [mailto:cass@ophiuchi.net]
Sent: Thursday, January 17, 2002 2:34 AM
To: Provost, Stephane
Cc: Debian Laptop List
Subject: Re: Xircom hangs on a Tecra 8000

Hmm... Okay, being an avid user of the Tecra 8000 myself, I have a few
suggestions for you.

To start with - always use the PCMCIA slot in auto-select mode.
Then, always make the BIOS do the interrupt allocations.

>From then, things start getting interesting, and so I would need to ask some
questions, starting off the questions :- Are you using the default Debian
kernel, or have you upgraded it?  What Xircom card do you have?  And, have
you yet upgraded the bios on the Toshiba?

If you haven't upgraded the Bios, I recommend it.  As does Toshiba - the
Tecra 8000 has some problems with win2K without upgrading, and the win2K
issues can cause problems elsewhere (at least Toshiba claims so).

If you have still have hassles after this, I'll be happy to help out...


----- Original Message -----
From: "Provost, Stephane" <sprovost@nuera.com>
To: <debian-laptop@lists.debian.org>
Sent: Wednesday, January 16, 2002 7:57 PM
Subject: Xircom hangs on a Tecra 8000

> Hi,
> I have a Tecra 8000, running Debian 2.2r5, with a Xircom Fast Ethernet +
> modem adapter. I got the pcmcia tools to work properly, everything (PCI
> pcmcia, ethernet card and modem) is using irq 11.
> The Ethernet adapter is detected and configured. I tried to force the
> driver to use the resources that matched the most Win2000's configuration
> panel, that is:
> io_port = fd00-fdff
> irq = 11
> memory = <assigned by OS>
> Actually, Windows reported an io list of fd80-fdff but the cardmgr didn't
> like it, so I bumped it to fd00-fdff and it worked.
> But as soon as I do an "ifconfig eth0 up", linux freezes. I can do nothing
> but reboot. The leds on the card are still there, the system looks good
> frozen.
> My kernel supports all the APM flags, serial irq and so on (as I found
> earlier in the mailing list), the BIOS is set to Cardbus 16-bit, but
> doesn't work. I tried different IO ports, different memory address, always
> freezes. I tried to force it to fd80 for IO port, cardmgr complained about
> not being able to allocate 136 IO ports (?).
> If anybody can point me to a patch, a setting in the kernel, ANYTHING,
> please help me !
> Thanks !
> --Stephane
> --
> To UNSUBSCRIBE, email to debian-laptop-request@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact

Reply to: