[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: GDM doesn't recognize keyboard anymore

On Fri, 2001-12-28 at 09:43, Ines Rieger wrote:
> Hi *,
> I have done the following:
> I have run the configuring-script from the gdm-chooser menu to apply a
> diffrent looking to my login screen. I only changed to pictures, nothing
> more. After that the chooser told me that no x-servers or xdcmp (?) where
> specified, that this only could be a configuration error and that he is starting an
> x-server. I activated this xdcmp(?) option and restrated my laptop. After
> that gdm didn't start anymore. So I deactivated it again. Now, gdm starts,
> but it doesn't recognize my keyboard anymore. I tried reinstalling gdm but
> that didn't work. I can't even switch to any console because my keyboard
> does not work. Does anyone know what I have done wrong?
> Greetings
> Rotschopf
Halloo, Rotschopf!

I've had a similar problem with gdm. I solved it by removing gdm and
installing a different version of gdm. I'm sorry I can't be more
specific, but I've forgotten the versions involved.

To remove gdm you'll have to log in in non-X mode. You probably already
know how to do this, but if not, boot up in "single mode." That is, if
you're using Lilo and your Debian entry is called "Linux", when you see
the Lilo prompt press Shift and type "Linux single" and then press
enter. You'll boot up into a non-X, non-network mode, and you can then
log in as root and type "apt-get remove gdm." Then go to Debian's web
site and use the package search feature to find the different versions
of gem available. Pick a different one, download and try it (install it
with dpkg -i).

Good luck.

Reply to: