[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: irda on a Inspiron 8100... (fwd)


On Monday 10 December 2001 01:02, Rob Hensley wrote:
> Hi, I was just curious if anyone's been able to get the irda working on an
> insprion 8100. If so, what chipset is it and how do i go about configuring
> it?! Any help to this would be greatly appreciated, I know i'll prolly end
> up needing lirc, I just don't have a clue how to configure it. One thing I
> did find out though, whenever I'd start lirc, my laptop would lock
> up...anyone else expierience this? Once again, thanks in advance!

just a few minutes ago it worked first time for me. Here's what I did:

- apt-get installed latest irda-tools/-common from testing (0.9.14) / Debian
- irattach /dev/ttyS1 -s
- modprobe ircomm-tty

Kernel is 2.4.16, nearly all irda protocol and debug options compiled in as a 
module. The machine is a Dell Inspiron 8100 and there is an SMC Infrared 
controller chip in it.

Right now I can connect via minicom to the internal modem of a Siemens S25. 
Note: the maestro3 sound drivers are not loaded, I saw a note about conflicts 
between the Maestro3 chip and the SMC IR transceiver on 
http://mobilix.org/ir_misc.html.. maybe that's why it failed until now.

Syncing an old Palm III via IR has just worked, too.

In the BIOS "Slow IR" and "COM2" are chosen. When loading smc-ircc first time 
it bails out with errors, but loads happily the second time. However, it's 
unused (says lsmod), of course, since IR is handled by ircomm etc. Don't know 
more about Fast Infrared yet.

 Frank Trenkamp                            ftrenkam at uos.de
 PGP fprt: 5A0C 4AE9 74A5 51F0 2D34  E7DC 67FF 32C4 0357 5653

Reply to: