[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Kernel compilation problems



On Tue, Oct 30, 2001 at 06:22:33PM +0100, Arne Jørgensen wrote:
> Hello,

Hej!

Another Jørgensen! Wow!

> 
> recently I bought a Toshiba Portege 3020CT notebook and installed
> Debian  Potato on it.
> 
> It worked.
> 
> I installed the kernel-source-2.2.19 package and recompiled the kernel
> to support APM and some other things.
> 
> It still worked.
> 
> Then I wanted to use DHCP, but it didn't work and after reading some
> documentation I tried to enable some kernel options (forgot which, but
> I was probably too eager and enabled/disabled some other options as
> well).
> 
> Now the new kernel wouldn't boot. And I haven't got any idea what made
> the diffrence (I have tried a lot changes without succes).
> 
> During the booting of the new kernel I end up with this error message:
> 
>        request_module[block-mojor-3]: Root fs not mounted

Looks like you have IDE support compiled as a module, rather than into
the kernel. And without IDE support, well...

>        VFS: Cannot open root device 03:03
>        Kernel panic: VFS: Unable to mount root fs on 03:03
> 
> Does anybody have some ideas?
> 
> The laptop is not connected to the network at the moment, but it will
> be later (this still works) and I will be able to post some log files
> if needed.
> 
> I still have an old, working kernel so I'm not completely lost.
> 
>         /arne
> -- 
> stud. scient. Arne Jørgensen
> Kollegium 5, 2. v. 222, Universitetsparken, DK-8000 Aarhus C, Denmark
> phone: +45 89 42 72 22, mobile: +45 21 65 01 13
> email: arne@daimi.au.dk, http://www.daimi.au.dk/~arne/

Hope this helps
-- 
Karl E. Jørgensen
karl@jorgensen.com
www.karl.jorgensen.com
==== Today's fortune:
Experience varies directly with equipment ruined.

Attachment: pgpZZRr4h8Za9.pgp
Description: PGP signature


Reply to: