[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: CDRecord USB IomegaZipCD650

On Tue, 09 Oct 2001, Guillaume wrote:


> dmesg:
> Attached scsi CD-ROM sr0 at scsi0, channel 0, id 0, lun 0
> sr0: scsi3-mmc drive: 24x/24x writer cd/rw xa/form2 cdda tray
> * sg0 is actually the dev that I can use sg0:0,0,0

Assuming that this is from when you plugged it in, not when you ran
CD-record, you are probably in luck. SCSI3-MMC is a well defined
standard for drives and (in theory) should work with one of the drivers
in cdrecord.[1]

>> You may have luck using the 'scsi2_cd' or 'mmc_cd' drivers. 
>> Otherwise, try to find out who iomega bought the hardware from and
>> which driver works for that sort of drive...
> tried mmc_cd/r and many more with no success.
> cdrecord: WARNING: Trying to use other driver on known device.
> cdrecord: Cannot attach driver for CD/DVD-Recorder.

Hrm. Check the cdrecord FAQ; there may be more details there. Pay
special attention to issues with the SCSI generic devices under Linux.
It sounds suspiciously like that might be the cause.

Not that I have much experience debugging that particular set of
problems, though.

Anyway, you tried the mmc_cdr and mmc_cdr_sony drivers as well? If so,
maybe it's time to email the author of cdrecord. :)


[1]  Unless, of course, USB emulates the SCSI type and the emulation
     isn't complete.

Absence extinguishes a small passion and increases a great one, 
as the wind extinguishes a candle and fans a fire.
        -- Francois duc de la Rochefoucauld

Reply to: