[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

PCMCIA and kernel 2.4.x (was: network connectivity problems)

At 12:14 PM 15/08/2001, Michael Heldebrant wrote:
> >On 10 Aug 2001 15:47:32 -0400, noah wrote:
> > > I'm running Woody on a Dell Inspiron 8000 - I have a cable Internet
> > > connection through a D-Link DFE-650 PCMCIA card. The connection worked
> > fine
> > > until I installed kernel 2.4.7 - now it doesn't work at all. It took some
> > > messing around to get it to work initially, so I've become somewhat
> > > familiar with dhcp and pcmcia - everything appears to be configured
> > > properly (the way it was when it worked with the older kernel), but I get
> > > no Internet.
> >Please clarify "no internet."  If no web sites come up, check if you
> >have explicit congestion notification turned on in the kernel.  you can
> >turn it off with a recompile or an echo 0 > /proc/sys/net/ipv4/tcp_ecn I
> >beleive.
> Thanks, I'll give this a shot - my criteria for no Internet were that I
> couldn't connect with Mozilla, but also that "ping whatever.com" returned
> "unknown host" - from what I learned getting the connection working with
> kernel 2.2.X, it looks like everything should work, but since I installed
> 2.4.7 I can't seem to connect.

This description of "no internet" now allows me to guess that a dns
problem is the core of it now.  What is your /etc/resolv.conf before and
after you connect with pppd and who is supposed to be your name server?


Thanks again for your help - apologies for the delay in replying, I've been fighting with this in several ways, and wanted to exhaust my options before coming back to the list (by the way, I'm now trying to upgrade to kernel 2.4.9, but everything else is the same).

I tried simply pinging an IP address, and I got a "network is unreachable" response for each ping attempt, so I assume that this means that it's not a dns issue - "ifup eth0" gives me the same response that it did under the 2.2 kernels, so it seems to be working, but it just won't let me connect - the light is on, the beeps are there, but no connection. I tried "route add default eth0," but that returned "SIOCADDRT: No such device."

I've found some information about PCMCIA problems on this notebook using 2.4 kernels, but the problem that other people seem to have had involves hanging due to IRQ conflicts, rather than just a dead connection.

In my research, I have found that opinions are split between "don't use the PCMCIA stuff in the 2.4 kernels, get the pcmcia-cs and pcmcia-source packages and install them" and "you don't need pcmcia-source anymore, everything you need is in the kernel" - since I wasn't having any luck with the second proposition, I tried the first, but I have been unable to successfully compile the PCMCIA module - it always dies with:

apa1480_stub.c:53: ../drivers/scsi/aic7xxx.h No such file or directory
apa1480_stup.c:79: 'AIC7XXX' undeclared here (not in a function)
make[4]: ***[apa1480_stub.o] Error 1
make[4]: Leaving directory '/usr/src/modules/pcmcia-cs/clients'
make[3]: ***[all] Error 2
make[3]: Leaving directory '/usr/src/modules/pcmcia-cs'
make[2]: ***[build-modules] Error 2
make[2]: Leaving directory '/usr/src/modules/pcmcia-cs'
make[1]: ***[kdist_image] Error 2
make[1]: Leaving directory '/usr/src/modules/pcmcia-cs'
Module /usr/src/modules/pcmcia-cs failed.

Ideally, I'd really like to just get the PCMCIA stuff in the kernel working, and avoid the hassle of the extra module all together - it seems to be so close (in fact, it gives every indication of working aside from the fact that it doesn't).

Thanks for any direction,

Reply to: