[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Some progress (Re: Debian setup freezes when trying to remove pcmcia)


Again, thank you everyone for your help so far with my problem. Here's what
I'm up to with this Xircom CardBus Ethernet II 10/100 on a Dell Inspiron 8000:
Last night I tried resetting the modem and after fiddling with ifconfig, dhcpcd,
and pcmcia-cs, I got this thing working! But only for a few seconds. I got
dhcpcd to get me an IP for ifconfig by running "dhcpcd eth0" and apt-get update
started updating, but froze after a few seconds. Next time I ran ifconfig, eth0 
was completely gone.

Here's what happens when I boot in right now. When I boot in, ifconfig
shows eth0 and lo, but no IP address in eth0. After running "dhcpcd eth0"
ifconfig shows an IP!!! But when I run apt-get update, the thing fails (I
probably waited too long) and when I ran ifconfig again, eth0 was gone
completely. Running dhcpcd again didn't help. eth0 was still gone. The trick
right now seems to be to keep eth0 with an IP address. I need/want to be
using dhcpcd. That's what has always ran for this RoadRunner connection.

Now if you guys think promiscious mode might help, is there a way to do it
for dhcpcd? If so, how?

- Bart

Reply to: