[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Trouble with X 4.0.3 on IBM T22 (kernel 2.4.5)

On Thu, Aug 16, 2001 at 08:39:14PM -0500, Matt Reynolds wrote:
> On Thursday 16 August 2001 08:12 pm, Thomas Fini Hansen wrote:
> > I'll bite. I can't quite get the network up after suspend on my
> > A20m. It used to work half the time, then I fiddled with it, now I
> > pretty much never works. Tried fiddling again as I'm tired of doing a
> > /etc/init.d/networking restart.
> >
> > But I got the the driver compiled in the kernel.
> No problems with the eepro100, or the cs46xx in the a21p.  These all can't be 
> that much different (right?).  Do you have any info from syslog?  What are 
> your kernel flags?

Syslog looks fine. Actually it looks like apmd doesn't run the scripts
it's supposed to or the NIC needs a bit more time to 'wake up' enough
for intuitively to work. Just doing a /etc/init.d/networking restart
as the first thing brings up the network just fine.

Added in some debugging to make sure it's not the first option.

Using ALSA for the cs46xx or the kernel driver? I used to use Alsa,
but when I had to reinstall (Doze, don't ask...) it was a bitch, and
the new kernel driver worked fine.

> I had problems with APM in 2.4.6, but moving to a newer kernel fixed all of 
> my problems (the recovery from sleep hardlocked the machine).

blade:~# cat /proc/version 
Linux version 2.4.5 (root@blade) (gcc version 2.95.4 20010522 (Debian prerelease)) #1 Wed Jun 6 12:30:00 CEST 2001

Hmmm... But it's not *really* failing. Sound seems to work. Well, of
course not today, but it's been working the last couple of days.

I'll see what my 'debugging'  comes up with.


Reply to: