[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

setserial use w/ pcmcia

i have a big problem with setserial.  when i first
install debian, everything works well.  the only
anomoly is after the first reboot i have to run
pppconfig again because modem changes from /dev/ttyS1
tp /dev/ttyS2.  When i upgrade to a 2.4.x kernel, it
again changes to /dev/tttyS4.

But my problem is when i install a new version of
setserial.  When I do, pppconfig is unable to find the
modem.  Debconf gives three choices when configuring
it initially: 

1) Auto-save Once
2) Autosave Always 
3) Kernel Settings

I've tried all three without success.  Always after
the first shutdown after upgrading setserial, the
modem is non-findable with a pppconfig auto-probe. 
Nor does it work if i manually set the /dev.

I've tried manually setting the setserial parameters
to what they are when they work, it doesnt help.  I've
tried reverting back to the original version of
setserial.  I've tried a new kernel build and
pcmcia-cs build.

I dont know what i can do.  Maybe someone here can help.

Do You Yahoo!?
Make international calls for as low as $.04/minute with Yahoo! Messenger

Reply to: