[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]


Can anyone help me to understand how my hibernation
system works so I can try to restore it?

I have a Sony Vaio F340 and the bios is Phoenix.
(Phoenix Bios 4, release 6).

Hibernation has not worked since I installed Debian.
In fact, when I try to invoke hibernation the screen
freezes up and I have found no escape sequence, such
as control-alt-delete or control-alt f2, that has any
effect so I have to turn off the power switch and restart.

The current partition table, from fdisk, looks like 


~# fdisk /dev/hda

Command (m for help): p

Disk /dev/hda: 240 heads, 63 sectors, 839 cylinders
Units = cylinders of 15120 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hda1   *         1       410   3099568+   b  Win95 FAT32
/dev/hda2           556       558     22680   83  Linux
/dev/hda3           559       839   2124360    5  Extended
/dev/hda4           411       555   1096200   83  Linux
/dev/hda5           559       830   2056288+  83  Linux
/dev/hda6           831       839     68008+  82  Linux swap


Debian is on hda4 and uses hda6 for swap.  Windows is on hda1.
Redhat Linux is on hda2 (/boot) and hda5 (/) and shares /hda6 as
swap.  Notice that hda4 is physically right after hda1.

The history of this setup is as follows.  The laptop came with
Windows98, with the 6 GB disk partitioned into a 4 GB "C" drive 
and a 2 GB "D" drive.  Without doing any new partitioning I installed
first Corel Linux and then replaced it with Redhat Linux on the 
former "D" partition.

At that point the hibernation feature still worked.  The partition
table at that time showed hda1 (4GB), and hda2, 3 (the extended
partition), 5, and 6 as above.  There was no hda4 in the table at that

When I installed Debian,  I left Redhat in place and formed the new
1 GB partition hda4 by shrinking the Windows partion hda1 to 3 GB
using fips.  That is when hibernation stopped working.

Is it reasonable for me to infer from this that hibernation used the end of
the original "C" partition hda1?  What I read mostly says hibernation
uses hda4 but the partition tables did not list an hda4 before I 
created it to install Debian.  Also, now that I have four primary
partitions I can not create a new hda4 as a new hibernation partition
as some have suggested, at least without reorganizing things in some way.  

Would there be some way I could reinstall hibernation in the last portion
of hda1 or elsewhere using something like phdisk or lphdisk or
some other means?  So far I have not located a description or 
documentation for phdisk.  

Thanks in advance to anyone who can give me an explanation of this.


Reply to: