[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

loadlin hangs after loading kernel and root image


With the help of Maarten Slaets I managed to let winme have the option
to boot into dos. So now loadlin works, but it hangs after loading the
kernel and root image. 
If I type (from the install.bat): 

loadlin linux root=/dev/ram initrd=root.bin disksize=1.44

it says that it loads the kernel and the root image, then it clears the
screen and the only thing left is a blinking cursor. The system hangs
rock solid.

I don't know how loadlin works (first time, use floppies al the time but
I don't have a floppy drive on this one), but I guess it is a kernel
problem, because loadlin only prints the dots for the loading of the
kernel and the root image, but does not give any output you see with a
normal linux boot. I've tried several kernels from debian (ao idepci)
and the latest 2.2 and 2.4 homebuilt and with different configs, but
nothing changed.  I've also tried different root images (idepci).

Can it also be a dos problem because it is hacked winme?

The system is a sony vaio c1ve (european c1vn) with the transmeta crusoe
The distribution is debian.

Tia for any info!


Reply to: