[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problems with 2.4.0, pcmcia-cs, and kernel package

On Sun, Jan 07, 2001 at 03:32:14PM -0500, Brian Connelly wrote:
> Welp, I've been trying to build and install 2.4.0 on my Sid machine, and
> I've been running into problems when I run:
> /usr/src/linux# make-kpkg --revision=blah modules_image
> I get the following:
> ...
> umask 022; make DEB_MOD=yes all
> make[3]: Entering directory `/usr/src/modules/pcmcia-cs'
> /bin/sh: -c: line 1: syntax error near unexpected token `;'
> /bin/sh: -c: line 1: `set -e ; for d in  ; do make -C $d ; done'
> make[3]: *** [all] Error 2
> make[3]: Leaving directory `/usr/src/modules/pcmcia-cs'
> make[2]: *** [build-modules] Error 2
> make[2]: Leaving directory `/usr/src/modules/pcmcia-cs'
> make[1]: *** [kdist_image] Error 2
> make[1]: Leaving directory `/usr/src/modules/pcmcia-cs'
> Module /usr/src/modules/pcmcia-cs failed.
> Anyone have any ideas?  Does the version in pcmcia-cs not work with the
> 2.4 series?  I don't think that's the problem.

I've compiled 2.4.0 with the latest pcmcia modules (3.1.23-1), and it went
fine, without the problem you described.  The modem works, I have some
problems with the modem locking up for no reason, but the rest of the time
it works fine.

It sounds like you have some corrupted scripts.  Have you got a clean source
("apt-get source pcmcia-cs")?  Do you have the latest kernel-packages (are
you using make-kpkg?) ?


ps on a different note, has anyone used the 2.4 kernel's own pcmcia modules?
They seem to be missing a lot of drivers, e.g. xirc2ps_cs isn't there.

PGP public key available at http://dparsons.webjump.com/drewskey.txt
Fingerprint: A110 EAE1 D7D2 8076 5FE0  EC0A B6CE 7041 6412 4E4A

Reply to: