[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: I got me a laptop :)

On Sun, Nov 05, 2000 at 10:23:40AM -0900, Aaron Dewell wrote:
> On Sun, 5 Nov 2000, CaT wrote:
> > 1. Sound. This laptop has an ESS ES1980 PCI sound card. Neither of the
> >    ESS options in the kernel worked. Does anyone know if it's possible
> >    to get sound out of this sucker under linux?
> > 
> >    Here's the lspci output for it btw:
> > 
> >    00:0c.0 Multimedia audio controller: ESS Technology: Unknown device 199a
> > 
> >    (doesn't look promising :/)
> If it's a newer device (like the Maestro-3 in my laptop) that isn't
> supported/recognized by the OSS/Free drivers in the kernel, you might
> check out www.alsasound.com or www.opensound.com.  The latter will cost
> you $30 for the base+driver, but they are pretty solid.  

I'm going to go and try the free package... which i believe is like what they're
selling except that it only last for 7 days or something, no?

> Of course, your problem could be something else, too, try updating to
> the latest kernel, too.

Already on 2.2.18pre19. Might try 2.3.x but am a wee bit fearful of
fs corruption.

> Actually, come to think of it, yours could actually be a Maestro-3 as 
> well.  Here's mine:
> 00:08.0 Multimedia audio controller: ESS Technology ES1983S Maestro-3i PCI Audio Accelerator (rev 10)

Mine's an ES199a:

00:0c.0 Multimedia audio controller: ESS Technology: Unknown device 199a
        Subsystem: Gateway 2000: Unknown device 5300
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 2 min, 24 max, 64 set
        Interrupt: pin A routed to IRQ 11
        Region 0: I/O ports at 1000
        Region 1: Memory at e8000000 (32-bit, non-prefetchable)
        Capabilities: [c0] Power Management version 2
                Flags: PMEClk- AuxPwr- DSI+ D1+ D2+ PME-
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-

> > 2. Modem. The mini-pci card in this sucker is both an eepro 100 and a
> >    real modem (not a winmodem - the sales guy was adamnant about that
> >    and sounded like he knew what the difference was :). The card is a
> >    Xircom and here's the only details I have atm:
> > 
> >    00:0d.0 Ethernet controller: Intel Corporation 82557 [Ethernet Pro 100] (rev 09)
> >    00:0d.1 Serial controller: Xircom: Unknown device 00d3
> As long as it recognizes a serial device, it should assign in a ttyS* and 
> use it.  Did you try out minicom/seyon on it?

Yes but no go. tried playing with setserial but it ddn't do anything. As I said
in a prev letter I do have the irq and io port but the modem don't wanna play
ball. :/

> I'm assuming the ether card works for you?

Yes. Beautifully.

> > 3. Gfx card :) Which X driver is the best for it? It's a
> > 
> >    S3 Savage IX Multi Display Accelerator. 2X AGP 8MB SGRAM
> You can get it to work in one of two ways.  Using the frame buffer
> X server and compiling in VEST FB support in the kernel.  Pain in
> the butt and rather slow (non-accelerated), but it works.  Or, you

Console framebuffer is slow enough with vesa support. 8( don't think
I could take X being this slow or slower...

> can grab the "beta" version of this driver.  This was the URL given
> to me by someone at XFree86.org, and works on Savage IX and MX:
> http://www.probo.com/timr/savagemx.html

Got this very site off my friend (only remembered it after I sent
out the email). The driver from it works great so far.

> You may want to check and see if it has been rolled into the main 
> XFree distribution yet, if it has, go for that.  This download is
> just a replacement for XF86_SVGA, nothing else.

Nope. Least not that I saw from my fiddling with the debian svga

> Good luck!

Thanks. I hope I can get sound and modem to work. That'd be too cool...

CaT (cat@zip.com.au)

	'We do more then just sing and dance. We've got a brain too.'
		-- The Backstreet Boys

Reply to: