[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

For Stormix, why won't my compiled APM work?

I have an IBM ThinkPad 1412 laptop, and I installed Storm 2000 (hail)
because (for me) it was easier than trying to configure a straight
potato release (in particular, my distro got screwed up when I installed
stuff from dselect and I didn't know how to disable prior select/install
attempts from dselect.  Things got messy...).

Storm "hail" doesn't come with apm support in the kernel.  I tried
compiling it in and figured out I could install both the kernel and the
modules by first uninstalling the same packages in dpkg, then installing
my stuff.  (When I compiled with make-kpkg and then "dpkg -i *deb" the
new packages conflicted with the current stuff and nothing installed.)

I installed the stuff (including a lilo) and the computer wouldn't power
off on "halt" command.  I tried it with and without "APM BIOS on
shutdown support", and both ways with and without --append="apm=on"--
in LILO.  In all four instances I couldn't get powerdown to work.

I have since changed my kernel and modules to the Debian 2.2.17pre6 of
potato and I get working APM built-in, as long as I put 
in the /etc/lilo.conf.  So I've no complaints there.

My question is:  what did I do wrong with the Storm-supplied kernel
(2.2.16) that APM wouldn't work after recompile?


Jerome Mrozak          "Never buy a dog and bark for yourself"
goose@enteract.com     --"Slippery" Jim DiGriz
                         (the Stainless Steel Rat)

Reply to: