[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: cdrom "exec" permissions denied

On Sat, 7 Oct 2000, J. R. S. Brownson <jrsb@geology.wisc.edu> wrote:

> On 7 Oct 2000, Daniel Pittman wrote:
>> The line you specify right there should tell you what you want to
>> know: you[1] have specified, amongst the other mount options, that
>> you do not want executable code, suid code and device files to be
>> usable on the CD.
>> So, to get executable stuff running off it, remove 'noexec' from the
>> mount options in fstab and remount the CD.
>>         Daniel
>> Footnotes: 
>> [1]  Well, whoever wrote the fstab, anyway.
> Actually, I already tried directly editing the fstab file and the
> /etc/pcmcia/cdrom.opts file to remove any incidence of "noexec". Both
> with the same result upon acitvating the cdrom in Gnome and checking
> "mount" afterwards: /dev/hdc on /cdrom type iso9660
> (ro,noexec,nosuid,nodev)
> Thanks, is there any other file I can dig into to avert this default?

Hrm. Not that I can think of, I am afraid. I had though that the GNOME
CD mount stuff simply ran the mount command with the right fstab

Anyway, I don't actually know GNOME, I am afraid, so I can't suggest
where it thinks it should look for this information. Does mounting
directly from the fstab (without the noexec there) work?

If so, you might have better luck on one of the GNOME specific mailing


What was once called the objective world is a sort of Rorschach ink blot,
into which each culture, each system of science and religion, each type of
personality, reads a meaning only remotely derived from the shape and color
of the blot itself.
        -- Lewis Mumford

Reply to: