[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: kernel 2.2.15 and pcmcia 3.1.8

On Fri, Jun 09, 2000 at 12:50:17PM -0400, Charles Baker wrote:
> Has anyone gotten this too work?  I downloaded the source packages. 
> Configured my kernel, compiled with make-kpkg, compiled the modules w/
> make-kpkg.  I got the unresolved symbols errors.  PCMCIA doesn't work. 
> Tried again w/ Configure script pointed to earlier on this list, it
> fails doesn't even compile the pcmcia stuff.  I can of course give more
> detail if it's required, I was just interested to see if it's working
> for anyone else.

I have had this problem with both kernel 2.2.14 and 2.2.15 using the
pcmcia 3.1.8-x package.  In short, it appears this version of pcmcia
is broken.  I refer to the following link:



[26-Jan-00] Version 3.1.9
-- Added workaround for serial-driver initialization bug, that messes
   up devices at non-standard IO ports.
-- Made PCI interrupt table lookup mandatory, and changed pci_csc and
   pci_int to default to "on" in the i82365 driver.
-- Updated tulip driver to Donald Becker's "0.91g" version.
-- Various updates for 2.3.37 and later kernels.
-- Filled in some gaps in dump_cis output.

This confirms what I've suspected about pcmcia, see my earlier thread
on this topic.

A post earlier today gave a work-around which I've used with success
after modifying it slightly.  Try this:

cardctl eject
rmmod serial
modprobe serial
cardctl insert

After these commands, my dialout again worked as expected.  I intend
to write a short script to execute these commands after each system
restart until pcmcia is advanced past 3.1.8, or when the problem
disappears, which ever happens first.

Can someone make sure this bug is properly reported?  I'm not sure
what to do.

- Nate >>


 Wireless | Amateur Radio Station N0NB          | "None can love freedom
 Internet | n0nb@networksplus.net               | heartily, but good
 Location | Wichita, Kansas USA EM17hs          | men; the rest love not
   Wichita area exams; ham radio; Linux info @  | freedom, but license."
             http://www.qsl.net/n0nb/           | -- John Milton

Reply to: